Remote control of Asterisk Server at operating system leve (linux) from remote desktop running Vista

I have had Asterisk up and running for several months now and want complete control of it remotely. I can access the “asterisk” part through the browser through FreePBX. I would aslo like to be able to remotely control the server at the operating system level (command line) from my desktop running Vista ultimate.

I have looked at products such as FreeNX from Ubuntu and others . My understanding is that FreeNX is designed to be implemented with the Ubuntu engine for Linux and so it doesn’t work with the default setup of TrixBox.

There are other products such as; realvnc, tightvnc, and uvnc, but they don’t come highly recommended for Vista.

Any ideas, I am sure many of you have already done this.


I’m not clear what you are really asking for. Do you simply want a terminal window into your server? Or are you trying to run an XWindows Server application on your PC to runs the OS’s GUI?

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

I use ‘Putty’ for remote SSH access to all our servers.
I’ve never used it with Vista but it is supposed to be compatible.

PuTTY is a fine terminal for windows systems, it lets you log into a shell and run command-line stuff (which on a server, is typically all you need).

If you’re trying to get the graphical desktop (eg, a Xwindows environment, like Gnome or KDE) on your local machine, VNC is probably the simplest way to go. TightVNC and UltraVNC are both clients that will do that. I can’t imagine the viewers have problems with Vista - but then who knows. I can see the server part of them having problems (eg, if you wanted to remotely log in to your vista desktop), but that’s not what you’re trying to do here.

Install the VNC server on your server, and then install a VNC viewer on your desktop, and you should be good to go.

Greg MacLellan - Core FreePBX Developer
http// - #freepbx

I misread the original post, I though it was for a system running Ubuntu…
I now see it’s for Trixbox which I think is Centos based.

I have never tried this with an Asterisk server, but on a standard Centos setup the VNC server is built in.

I’ve tested it with a Centos 5 machine (but I think it’s also available on Centos 4).
On the Centos machine, go to System -> Preferences -> Remote Desktop and tick the boxes for
’Allow other users to view your desktop’ &
'Allow other users to control your desktop’
and also set a password…

I think you have to log out & back in (or reboot) to enable it.

You can then get graphical remote access using a standard VNC client (eg RealVNC).

If you go to Tools/System Administration/Module Admin in FreePBX you can download and install Java SSH - this works great for me on Vista with Firefox.


Thanks for the input. I am not sure exactly where I can find “System -> Preferences -> Remote Desktop” and tick the boxes on the Centos Machine. I have seen them on a Windows macnine.

I only have a command line interface that I know of on the Linux box. Is there a graphical interface installed with the default Trixbox setup that I am unaware of.

Also, has anyone actually installed the "RealVNC’ setup on an asterisk machine from the command line. If so, any help that you could give me would be very much appreciated.

Thanks again for all of the input.

What you are really looking for doesn’t exist per say and when you make it exist it is NOT recommended…

Running a GUI on any asterisk box taxes the crap out of it. use a terminal (telnet bad choice from security point of view, that 's why it’s not enabled) or ssh which is secure telnet.

If you have a GUI installed you can install VNC which does exist for CentOS. But Linux is NOT Windows and does not have that magic check box for way to many reasons to get in to.

I can’t say it enough learn Linux at the command line level first so you know what you are doing, it will serve you very well if you do. The GUI makes things look pretty and from a system standpoint I can’t think of a single thing that a GUI can do that the good one command line can’t.

Yes doing graphic editing, surfing the web, etc that’s what a GUI is for but that’s not what you should be doing on a phone system.

This question is well addressed and covered in the trixbox forums. so take a look there for all the information.

Is some software which will allow them to access their Trixbox machine from another computer on their network or on the internet. Trixbox comes with SSH on by default (one of the many reasons to make sure you change all of your passwords to non-standard ones.) Just download a program like Putty (It’s free, use Google and search for it) and you can then “remote” into your trixbox machine. You will get a login prompt and it will look like you are sitting at the monitor on your Trixbox machine.

You can login with your standard login or with root, if you so desire.

This doesn’t give you a graphical interface. It’s all command-line. :slight_smile:


You are correct. But if you read his comments he wants to enable the GUI which we all know is NOT the thing to do.

From his post this morning “Thanks for the input. I am not sure exactly where I can find “System -> Preferences -> Remote Desktop” and tick the boxes on the Centos Machine. I have seen them on a Windows macnine.”

SSH was offered way up at the top and he said no he wanted a GUI.

Hello all and thank each of you for your responses. Before deciding to look for a GUI for trixbox, I tried getting SSH to work but had no luck. Taking the advice of the forum, I am trying once again. I am not having any luck getting Java SSH (FreePBX/ Tools), SSH terminal (Trixbox/System), or Putty to work. I think my problem with them is the same.

With Java SSH, I Get a pop-up window from MindTerm of appgate with the i.p.address of my asterisk server at the bottom. I get “Error connecting to, reason: -> Connection refused: connect.”

With Java Terminal, I just get an SSH termal window opening up and “connected to” at the bottom and a box for the Username and Password. I have entered the same username and password that I use for the command line on the asterisk server but I get nothing. Not an error, not anything at all.

Using Putty from a Windows XP machine, I get “Netowrk eror: Connection refused”.I am using the default port “22”.

My asterisk server is setup as a DMZ on my network.

Any advice you could offer would be greatly appreciated.

Is there anything special that I have to do on the asterisk server to all these connections?

ah, sitting in a DMZ, yea allow traffic to port 22 for ssh otherwise the firewall is blocking it.

The web admin pages and a putty shell should give everything you could possibly need to work on the box. Keep in mind that putty can tunnel ports, so if the only access you have is putty then you can use that to access anything else on the target by tunneling local ports to remote ones, very handy.

Thanks again for the input, port 22 is forwarded to the asterisk server. Tried putty, SSH, etc, but no success. Noticed that my secure shell server is 'stopped" Have rebotted several times, but no success.

Also, I noticed on bootup that HTTPD fails and gives the message “Starting sshd: /etc/rc3.d/S55sshd: line 111: /usr/sbin/sshd: No such file or directory”

I verified with the command line that the directories didn’t exist and manually created them. Still doesn’t work. Tried re-installing httpd after creating the directories, stilll no success.

Any ideas?


if /usr/sbin/sshd does not exist then ssh was not installed (real strange) or it was deleted.

I installed httpd, ssh, sshd by the following commands:

yum -y install ssh
yum -y install sshd
yum -y install httpd

I assume that is correct:

I still get the errors above.

Any other suggstions?


If you installed as you say (and I’m not questioning your statement or skills), and it did it, then there is something seriously wrong. As the install should have placed the program in the proper location and it would then be found. At this point the issue is basic Linux installation issues. While you can get answers here you might be better off looking for direct support of the base OS. I’m not 100% sure what your OS is. I see mentions of trixbox which is CentOS (I run trixbox and it automatically install everything you need, configures it and starts sshd and httpd), but also Ubuntu.

So I hate to say it but you might be better off starting from scratch and building a basic box that works correctly and has all the required dependencies first before you install asterisk then freepbx on top of that.

If this is a trixbox install then something went horribly wrong and it would truly be better to backup your files and start over.

Thanks for the reply. This was a trixbox install. I will probably just reinstall it again, hoping the problem will go away.


Re-instlaled Trixbox and it worked fine. Even used exactly the same disk for install.

Anyway, thanks for all of the input. It was very helpful.