Remote Client Extensions not registering properly

Hi all,

I’ve been ripping my hair out over the last few weeks trying to figure out why we cannot get remote extensions working correctly.

Currently we have an internal system that works fine and we are wanting to allow external registration of users extensions so they can be contactable via a softphone when working from home. I have opened UDP ports 5060 for sip, or in our case pjsip as we have binded port 5060 to pjsip for our instance. And ports 10000-40000 for RTP. Our system is NATted and I have tried the configuration in DNAT & Full NAT which no difference.

The issue seems to be that communication is not making it back to the remote softphone. I say this because when I connect the remote softphone it registers successfully on the softphone end. However on the PBX it shows the IP registration but next to it states ‘unavailable’ and when you try and call the extension the call does not go through. Ontop of that if you call from the remote extension to an internal phone the call goes through successfully and both parties can hear each-other.

I’ve been wading through the logs and found this when the remote phone first connects;

[2018-02-16 10:30:59] VERBOSE[12680] res_pjsip/pjsip_configuration.c: Endpoint 2030 is now Reachable
[2018-02-16 10:31:01] VERBOSE[12680] res_pjsip/pjsip_configuration.c: Contact 2030/sip:[email protected]:48073;rinstance=3076376c99ab1810 is now Unreachable. RTT: 0.000 msec

It seems like the phone registers but goes unreachable straight away.

I’d appreciate any suggestions.


There’s some NAT options you have to change in the extension settings, don’t remember what it is, I can check next time I’m by my desk… :slight_smile:

I’d appreciate if you could point me to the direction of them. I see a couple of NAT related settings in the SIP extension settings but not in the pjSIP extensions that we are using here :slight_smile:


You can also try to add your public IP in your ChanSIP settings.

Restart asterisk once you made these changes.

Doesn’t seem to have worked, I changed the extension settings to match your screenshot and also changed the ChanSIP IP setting from public to static and entered our static IP from our ISP. Still seem to have the same issue of communication not making it back to the remote extension.

I’d appreciate anymore suggestions

Did you restart Asterisk after making the changes? That worked for me.

Yes, I did amportal restart in the cli

Ahh, i got it working on FreePBX 14 Asterisk 14, it seems that you have a very old version of FreePBX (and probably Asterisk too) if you are still running amportal commands.

Sorry that’s me not concentrating, I’ve used older versions before. I used fwconsole, just used to typing amportal.
Our PBX Firmware:10.13.66-22

Oh and asterisk 13.18.3

I’m not familiar with PJSIP, not too long ago i asked this here. and what i posted worked for me… Trying PJSIP no audio on endpoints

Okay thanks for the post. I’ll take a look. Cannot understand why this wont work now

After a bit more testing it looks like the issue is with Pjsip as I changed the extension driver to ChanSIP and it worked fine. However using ChanSIP isn’t really ideal so if anyone has any suggestions as to why ChanSIP would work but Pjsip wouldn’t that would be great


Have you checked if your port are opened from the external . Sip and PJSIP doesn’t use the same port .

Yes we have PJSIP on port 5060 which is open and moved SIP to 5065

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.