Reload Failure

I’m running latest 64 bit distro. Freepbx 2.10 Asterisk 1.8

Upon attempting an “apply config” i get the following

Reload failed because retrieve_conf encountered an error: 1

exit: 1
[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting

Dashboard Shows Asterisk Red. (also for some reason shows ssh yellow, yet i can connect to the box using ssh over port 22)

I waited till after hours, did a server reboot hoping to get lucky and same result. I began scouring forums, and after finding much seemingly outdated information, I came upon this thread.

I get from that Freepbx is trying to connect to the AMI with a different password than what’s in manager.conf
But i haven’t attempted to change any password, nor have i updated any modules (though i did update the framework to the final from rc1 in hopes it would resolve the issue)
The ami password in amportal.conf manager.conf, and advanced settings hidden settings are all “amp111” which was set by the distro at time of install.
Asterisk manager host is localhost and port 5038, which i can connect to.

Bind address in manager.conf is (default)
i tried changing it to with no change
i have ensured selinux is disabled.

What could have caused this?

So I decided to check the obvious… Ping localhost… and it failed.

Somehow the interface stopped looking at the hosts file and just dns… odd


I am having the same problem; how did you manage to fix that?

Ping localhost
you should get replies. If not something has probably happened to your hosts file.

ensure localhost resolves to

make sure hosts file is checked before dns server