FreePBX | Register | Issues | Wiki | Portal | Support

Reload failed because retrieve_conf encountered an error: 255


(Erazmus) #1

Just upgraded from the alpha to the beta for FreePBX 13. I was getting a permissions error, which I fixed with ‘fwconsole chown’. Now I’m getting the following error, which I don’t know how to fix. Any ideas?

exit: 255
Unable to open /dev/dahdi/ctl: Permission denied
PHP Fatal error: Cannot use object of type DB_Error as array in /var/www/html/admin/modules/manager/functions.inc.php on line 71
Whoops\Exception\ErrorException: Cannot use object of type DB_Error as array in file /var/www/html/admin/modules/manager/functions.inc.php on line 71
Stack trace:

  1. () /var/www/html/admin/modules/manager/functions.inc.php:71

#2

They already have this in a ticket from one of the developers. I saw and reported also in another ticket with multiple issues: http://issues.freepbx.org/browse/FREEPBX-9526


(Erazmus) #3

Thanks! I will keep an eye on the ticket.


(Tony Lewis) #4

We know what the issue is with upgrades just not a easy fix but we are working on it.

You can do this to solve your problem.

[root@asterisk ~]# fwconsole ma install -f manager


(Erazmus) #5

I can confirm that this workaround worked. Thank you!


(Andrew Nagy) #6

This has been resolved but requires framework to be updated individually before any other modules (and/or not grouped with any other modules)


#7

Missed this last post. Thanks for that update. The workaround also worked for me.


#8

I still have this problem.
When I use fwconsole ma install -f manager, there isn’t any change?

I’ve updated from FreePBX Distro 6.12.65-24 to -25,-26, -27, -28, -29, -30, to 10.13.66-1 and so on to 10.13.66-5.

PBX Firmware: 10.13.66-5
PBX Service Pack: 1.0.0.0


(Andrew Nagy) #9

Uninstall manager and reinstall it.


#10

I’ve uninstalled Contact Manager and Certificate Manager as modules, but i still have the same error…

Reload failed because retrieve_conf encountered an error: 255
exit: 255
Unable to continue. SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘asterisk.userman_users’ doesn’t exist in /var/www/html/admin/modules/bria/Bria.class.php on line 295

If somebody can help me with this issue, please let me know. I’m just somebody that just started with freePBX some months ago so i’m not that good in it.

Thank you


(Andrew Nagy) #11

Completely different error…

fwconsole ma install userman


#12

Hi tm1000,

I’m afraid that i have to start all over again :sa:
This is the error that i get when entering the command “fwconsole ma install userman”

[root@localhost ~]# fwconsole ma install userman
PHP Fatal error: Class ‘FreePBX\modules\DB’ not found in /var/www/html/admin/modules/userman/Userman.class.php on line 93
Whoops\Exception\ErrorException: Class ‘FreePBX\modules\DB’ not found in file /var/www/html/admin/modules/userman/Userman.class.php on line 93
Stack trace:

  1. () /var/www/html/admin/modules/userman/Userman.class.php:93