Reload failed because retrieve_conf encountered an error: 255 exit: 255

I’m having this problem when I run an apply config. This comes after updating system and modules.

For other people who’ve had this problem, they had more information in their error, but I just have exit: 255.

I’ve tried restarting the system. But I think I probably need to uninstall and reinstall a module, but I don’t know which one, because of the lack of information from this error.

This is an extremely new system and I’m not sure why I’m getting this error.

Thanks.

Edit:

This reload problem did come after an upgrade to the modules and system, but also shortly after a test where I attempted to make 20 calls simultaneously using call files. I was attempting to test the ability of our network to handle a number of simultaneous calls. Strangely, only 2 made it out, and the others failed. From my inspection of a packet capture at the time, I think the number I was calling rejected the others, but immediately after, I started having problems connecting to trunks. Is it possible these are related issues?

From the bash prompt run:

fwconsole r --verbose

and see if there are more clues.

Unfortunately I just get:

[[email protected] ~]# fwconsole r --verbose
Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 255

I’m kinda stuck if I can’t get this problem resolved. It’s strange to me that a new install would cause these problems. I edited the first post to include 1 idea I had as to why it may have happened, other than updating the system. But I don’t think that should have broken it.

Am I not supposed to update the system using the update module? Should I have instead used yum update to do that? Or should I not have done it at all?

Unfortunately it seems like I’m having the exact same issue as you. This is a new pbx i’ve been working on and hasn’t been deployed yet. Everything was working fine and then suddenly i reloaded and have the same error with no details.

For me I traced my steps backwards. Last thing i had done was a couple of days ago I added a few trunks to the system, but never applied changes. Then today I tried to apply the changes and ended up with the error. I just removed the trunks I added and things started working again.

Does anyone know if there is a way to view the pending changes that need to be applied? it would certainly make it easier to figure out what changed settings may be causing a problem.

I ended up resetting my system again. Only to encounter the problem again. But this time, I know what happened.

I added a pjsip trunk.
Hit Apply Config
Then got that error.

I was able to delete the trunk, and that removed the apply config button, (I think, or hitting it just worked this time…)

Either way, I’m pretty sure this is a bug of some sort, because chan_sip trunks seem to be working OK.

I have set up a FreePBX server using the distro. Installed latest system and module updates and then started to configure the settings. The system is using PJSIP.

When adding a Trunk I click on Save and then the red Apply button appears at the top.

If I click Apply I get the following error:

“Reload failed because retrieve_conf encountered an error: 255”

Is this a known bug?

[moderator - merged this post to existing thread.]

known now - - anyway can you do me a favor go back into the trunk defintion and check out your sip server field …

my guess is its blank?

did some quick testing and encountered the same adding a new trunk -
specifically this error …

exit: 255
Unable to continue. Asterisk will crash if sip_server is blank! in /var/www/html/admin/modules/core/functions.inc/drivers/PJSip.class.php on line 407
#0 /var/www/html/admin/modules/core/Core.class.php(204): FreePBX\modules\Core\Drivers\PJSip->genConfig()
#1 /var/www/html/admin/libraries/BMO/FileHooks.class.php(97): FreePBX\modules\Core->genConfig()
#2 /var/www/html/admin/libraries/BMO/FileHooks.class.php(26): FreePBX\FileHooks->processNewHooks()
#3 /var/lib/asterisk/bin/retrieve_conf(878): FreePBX\FileHooks->processFileHooks(Array)
#4 {main}

i went back and built a new trunk with a new name carefull insuring i had entered the sip server ip/fqdn and submitted , trying to apply config was met with above error … going back and checking sip server field it was indeed blank; i was able to edit the trunk and add the info – reloading after this is successful

ill get a ticket written up for the dev team – thanks

1 Like

Interestingly, I never received that more in-depth error code. Also, it not only erased my server, it took out the password and username as well. Adding those back in let me apply config, but it seems like the server isn’t sending out those registration requests. I see an error in the logs:

[2018-01-28 18:00:37] ERROR[25876] res_sorcery_config.c: Could not create an object of type ‘registration’ with id ‘voipms’ from configuration file ‘pjsip.conf’

I wouldn’t mind rolling back temporarily to fix these issues, but I’m not exactly sure what module I should roll back to. Which one should I roll back?

https://issues.freepbx.org/browse/FREEPBX-16756

rolling back to core 14.0.4, the issue is not present

fwconsole ma downloadinstall core --tag 14.0.4

I’ve rolled back, but I’m still getting that error I sent above. Any ideas as to what might be causing it?

res_sorcery_config.c: Could not create an object of type ‘registration’ with id ‘voipms’ from configuration file ‘pjsip.conf’

Fixed in 14.0.5.9

1 Like

Delete your trunk and recreate them.

I can confirm this is working for me in 14.0.5.9

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.