Reload failed because retrieve_conf encountered an error: -1

I have a freepbx system that I’ve backed up from running on asterisk 1.6.2 and restored it to a system running asterisk 1.8. I reinstalled all the modules and things appear to be working pretty well except for one thing - reloads via the web don’t work. I should also note that this is a openvz container using OpenNode.

I did make sure both systems were running the latest 2.9 version of FreePBX before doing the backup and restore.

The error I get is “Reload failed because retrieve_conf encountered an error: -1” when I try to apply settings via a browser.

When I run module_admin reload on the command line it works without issue.

When I run retrieve_conf from a command line I get the following last few lines:

processing datasource =>
Please update your modules and reload Asterisk by visiting

I ran a module_admin upgradeall from the command line and it appeared to work (no errors reported). Everything is up to date if I check modules via the web interface too.

I don’t think this is related to the 1.6.2 to 1.8 upgrade…I think it may be a permission issue I can’t find or some other issue I’ve created in the system.

Any help would be appreciated.

I gave up and redid the configuration. Of course, now it works fine.