Rejecting unknown SIP connection from

Hello All,
I am setting up a new PBX, last distro available, and while I can call, incoming calls crash with the error message above.
I setup the PBX with firewall disabled to minimize initial setup issues, anyway we have one on our LAN.
I chose chan_sip because all the extensions were previously setup with that, setup one trunk, inbound, outbound route and one extension.
Here is the log:
[2020-04-29 18:38:01] VERBOSE[2940][C-0000000b] netsock2.c: Using SIP RTP TOS bits 184
[2020-04-29 18:38:01] VERBOSE[2940][C-0000000b] netsock2.c: Using SIP RTP CoS mark 5
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:1] GotoIf(“SIP/sip.messagenet.it-0000000d”, “1?setlanguage:checkanon”) in new stack
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx_builtins.c: Goto (from-sip-external,s,2)
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:2] Set(“SIP/sip.messagenet.it-0000000d”, “CHANNEL(language)=en”) in new stack
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:3] GotoIf(“SIP/sip.messagenet.it-0000000d”, “1?noanonymous”) in new stack
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx_builtins.c: Goto (from-sip-external,s,5)
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:5] Set(“SIP/sip.messagenet.it-0000000d”, “TIMEOUT(absolute)=15”) in new stack
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] func_timeout.c: Channel will hangup at 2020-04-29 18:38:16.814 CEST.
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:6] Set(“SIP/sip.messagenet.it-0000000d”, “receveip=recvip”) in new stack
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:7] Log(“SIP/sip.messagenet.it-0000000d”, "WARNING,“Rejecting unknown SIP connection from 212.97.59.76"”) in new stack
[2020-04-29 18:38:01] WARNING[30629][C-0000000b] Ext. s: “Rejecting unknown SIP connection from 212.97.59.76”
[2020-04-29 18:38:01] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:8] Answer(“SIP/sip.messagenet.it-0000000d”, “”) in new stack
[2020-04-29 18:38:02] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:9] Wait(“SIP/sip.messagenet.it-0000000d”, “2”) in new stack
[2020-04-29 18:38:04] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:10] Playback(“SIP/sip.messagenet.it-0000000d”, “ss-noservice”) in new stack
[2020-04-29 18:38:04] VERBOSE[30629][C-0000000b] file.c: <SIP/sip.messagenet.it-0000000d> Playing ‘ss-noservice.slin16’ (language ‘en’)
[2020-04-29 18:38:09] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:11] PlayTones(“SIP/sip.messagenet.it-0000000d”, “congestion”) in new stack
[2020-04-29 18:38:09] VERBOSE[30629][C-0000000b] pbx.c: Executing [[email protected]:12] Congestion(“SIP/sip.messagenet.it-0000000d”, “5”) in new stack
I must be missing something here…
Thanks for your time,
-Gian

I am no expert but I did/do have the same problem and just got a call from our PSTN service provider telling me that they blocked our international calls due to fraud.

I only have 3 extensions on Freepbx, FW is on and Intrusion detection is ON too, still someone connected to our Freepbx and made international calls even when my outbound dial plan only allows 8 digits.

I also just checked my call logs and I see a bunch of extensions that do not exist on my system. how is this possible?

Thanks

Luis

I have a Messagenet trunk and took at look at the settings. They are not the way I’d normally set up a trunk; I probably got them from another user’s post. If you want to give them a try:

IIII (Internal number)
PPPP (SIP password)
NNNN (phone number)

Peer Details:

host=sip.messagenet.it
port=5061
username=IIII
secret=PPPP
type=peer
insecure=invite
disallow=all
allow=alaw&ulaw

User Details:

secret=PPPP
type=user
context=from-trunk
insecure=invite
canreinvite=no
host=sip.messagenet.it
port=5061
realm=sip.messagenet.it
disallow=all
allow=alaw&ulaw

Registration String:
IIII:[email protected]:5061/NNNN

Thanks, Stewart1,

I had missed “transport=tcp” in Trunk/Sip/Outgoing tab.
Now it seems to be working. (fingers crossed…)
Funny that a missing parameter in Outgoing would prevent calls incoming.
But I’m a total noob at Voip…
In case you are interested, Messagenet has a tutorial, in Italian, though.

thanks lbrenes,
that was me test calling the PBX, so I am sure it was not a fraud…

Great to hear, hope you are able to solve your problem.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.