Rejecting unknown SIP connection from

freepbx
Tags: #<Tag:0x00007fafc71e1a08>

(Tom) #1

Hello,

freepbx on my raspberry is working fine. Last 3 weeks 700 Calls, 36hours duration.

But every few weeks nobody can call me. Freepbx is playing ss-noservice.g722 (The number you have dialed is not in service).

In the log I found „Received incoming SIP connection from unknown peer to“ and „Rejecting unknown SIP connection from 217.0.128.133“:

[2019-10-24 14:29:02] VERBOSE[26669] asterisk.c: Remote UNIX connection disconnected
[2019-10-24 14:29:24] VERBOSE[1237][C-0000007e] netsock2.c: Using SIP RTP TOS bits 184
[2019-10-24 14:29:24] VERBOSE[1237][C-0000007e] netsock2.c: Using SIP RTP CoS mark 5
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [929xxxx@from-sip-external:1] NoOp(“SIP/ims.telekom.de-00000127”, “Received incoming SIP connection from unknown peer to 929xxxx”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [929xxxx@from-sip-external:2] Set(“SIP/ims.telekom.de-00000127”, “DID=929xxxx”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [929xxxx@from-sip-external:3] Goto(“SIP/ims.telekom.de-00000127”, “s,1”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx_builtins.c: Goto (from-sip-external,s,1)
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:1] GotoIf(“SIP/ims.telekom.de-00000127”, “1?setlanguage:checkanon”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx_builtins.c: Goto (from-sip-external,s,2)
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:2] Set(“SIP/ims.telekom.de-00000127”, “CHANNEL(language)=de_DE”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:3] GotoIf(“SIP/ims.telekom.de-00000127”, “1?noanonymous”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx_builtins.c: Goto (from-sip-external,s,5)
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:5] Set(“SIP/ims.telekom.de-00000127”, “TIMEOUT(absolute)=15”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] func_timeout.c: Channel will hangup at 2019-10-24 14:29:39.345 CEST.
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:6] Set(“SIP/ims.telekom.de-00000127”, “receveip=recvip”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:7] Log(“SIP/ims.telekom.de-00000127”, "WARNING,“Rejecting unknown SIP connection from 217.0.128.133"”) in new stack
[2019-10-24 14:29:24] WARNING[26736][C-0000007e] Ext. s: “Rejecting unknown SIP connection from 217.0.128.133
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:8] Answer(“SIP/ims.telekom.de-00000127”, “”) in new stack
[2019-10-24 14:29:24] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:9] Wait(“SIP/ims.telekom.de-00000127”, “2”) in new stack
[2019-10-24 14:29:26] VERBOSE[26736][C-0000007e] pbx.c: Executing [s@from-sip-external:10] Playback(“SIP/ims.telekom.de-00000127”, “ss-noservice”) in new stack
[2019-10-24 14:29:26] VERBOSE[26736][C-0000007e] file.c: <SIP/ims.telekom.de-00000127> Playing 'ss- noservice.g722’ (language ‘de_DE’)
[2019-10-24 14:29:30] VERBOSE[26736][C-0000007e] pbx.c: Executing [h@from-sip-external:1] Hangup(“SIP/ims.telekom.de-00000127”, “”) in new stack

In the last 3 week I never found the message “Received incoming SIP connection” ?!?

My chan_sip SIP Setting:
username=xxxxxx@t-online.de
type=friend
secret=123456
qualify=yes
insecure=invite
host=tel.t-online.de
fromuser=0xxxxxxxx
fromdomain=tel.t-online.de
dtmfmode=rfc2833
directmedia=no
context=from-trunk
session-timers=refuse

SIP Settings:
Allow Anonymous Inbound SIP Calls=NO

Type=friend oder Type=peer doesn’t help.

If I reboot the raspberry the problem is fixed immediately, and everything is working fine for the next 4-6 weeks. I’ve been watching the problem for over one year now.

A cron reboot job every Sunday doesn’t help.


(Dave Burgess) #2

How many addresses does tel.t-online.de resolve to? I’m going to guess more than one, and further that only one of them is 217.0.128.133.

Chan-SIP can’t really effectively use FQDNs, you really need to use IP addresses, so you need an incoming trunk from every IP address that t-online.de is going to use.


(Tom) #3

Hi Dave,

thank you. Yes for me tel.t-online.de is 217.0.27.53.
Can pjsip work with FQDNs?


(Dave Burgess) #4

I’m not sure, but I do know that you can use more addresses than one with a PJ-SIP trunk. IIRC, you can set up a PJ-SIP trunk with an SRV record pointer, although that might be the result of a fever dream.

I only set up SIP trunks four or five times a year, and I always use the same provider, so I just have that configuration memorized.


(Joshua C. Colp) #5

Recent versions of Asterisk with PJSIP do have SRV support for identifying incoming traffic as you are referring to. It defaults to enabled and first tries to do an SRV lookup to get all possible addresses, and then falls back to a normal A lookup to get the addresses.


(Tom) #6

Hi Dave and Joshua,

thank you for your reply. Yes T-Online have a lot of IPs for tel.t-online.de. It is a big provider in Germany (~18 million landlines).

I believe that pjsip is the better protocol. But I asked me, why a lot of chan_sip configuration worked with this provider.

I think you give me a very good hint! The provider resolve tel.t-online.de to different IP addresses in different locations. They do load balancing with this.
My freepbx was using the DNS Server 1.1.1.1. Because of your hints I changed it to the provider dns server. Now tel.t-online.de have a different IP for my raspberry.

I hope it will work now. I will get the answer in a few weeks. If it doesn’t work I try to configure pjsip.

Thank you !!
Tom


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.