Regular Roundrobin queue no call waiting with Polycom phones

I need confirmation that the following setup works.

Regular queue on roundrobin
Polycom phones
Call waiting disabled (so the phones don’t ring the second line)

I want to know if somebody have accomplished this without having any problems with the phones still ringing the second line. I want to know if I am still doing something wrong of if it is a bug.