Registration string with @ in username


I’m trying to register a “trunk”, or mostly my provider SIP account with SIP credentials.
I can successfully setup the account on my phones or VOIP applications, but not in FreePBX.
My provider of course don’t make any support.

The problem, I think, is that the registration string I should use do not work as expected. This is because the username of the account contains the @ sign.

In the log, I have, a timeout registering to the wrong serveur, or a fail with the good server (and bad username).

I tried a lot of things without success. My provider don’t answer any question.

Have anyone a tip to register this correctly ? Or without the registry string ?
I’m kind of blocked. Thanks

For example :
host : swisscom . ch
registration serveur or outbound proxy
username +4xxxxx
password yyyyy
registration name [email protected] . ch

So in the log, I have a timeout for, or an failed on but for NC00XX (instead of [email protected]).
I tried to have these results to put or not some “” around.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.