Registering Cisco 7945G with Freepbx

Hi

we have a FreePBX 12.0.76.2, running on Ubuntu Server 14. We have Cisco 7945G phones which arent able to register, and get stuck on “registering”.

I have done extensive search, and tried solutions such as password length etc. My freepbx server shows
[email protected]:~$ netstat -an | grep 5060
udp 0 0 0.0.0.0:5060 0.0.0.0:*

My Sip FW is SIP45.9-4-2SR1-1S.loads

Pls help!

Hi Guys,

any help pls??

So many questions and so few relevant provided answers…

Are the phones “downgraded” to SIP, or are they still SCCP?
Are you trying to “flash” the phones over the network?
Do you have all of the image and config files for these phones?
Are they set up in DHCP?
Are they set up TO USE DHCP?
Is your server on the same network as the phones?
If so, why would your SIP firewall be part of the problem?
If not, how are you provisioning the phones?
Do you have TFTP set up?
Have you turned on the verbosity of the TFTPD program so that you can see what’s getting asked for in /var/log/messages?
Have you checked /var/log/messages for information from the phone?
If the phones are not set up for SIP, have you installed Chan-SCCP-B to act as the Channel carrier for your phones on the server? (We’ve been talking about this quite a bit again lately. Search the forums).
If you are desperate to cripple the phones, have you flashed them to the SIP Image?
If so, which one?
Have you enabled the firewall on the local network on the server? If so, turn off iptables (assuming you don’t have a publically facing SIP port).

Since the phone is locked at “Registering”, I actually know the answers to a few of these questions already. Believe it or not, if you can answer all of these questions, you should find your problem.

Are the phones “downgraded” to SIP, or are they still SCCP? - They are on SIP
Are you trying to “flash” the phones over the network? - NA
Do you have all of the image and config files for these phones? - Yes, downloaded from Cisco
Are they set up in DHCP? - Yes
Are they set up TO USE DHCP? - Yes
Is your server on the same network as the phones? - No
If so, why would your SIP firewall be part of the problem? - NA
If not, how are you provisioning the phones? - Didnt understand.
Do you have TFTP set up? - Yes, of course
Have you turned on the verbosity of the TFTPD program so that you can see what’s getting asked for in /var/log/messages? - Yes, no tftp issues
Have you checked /var/log/messages for information from the phone? - Yes, none. Ran tcpdump, phone does communicate with the server, but stops after ntp info
If
the phones are not set up for SIP, have you installed Chan-SCCP-B to
act as the Channel carrier for your phones on the server? (We’ve been
talking about this quite a bit again lately. Search the forums). - NA
If you are desperate to cripple the phones, have you flashed them to the SIP Image?
If so, which one? SIP 9.4, latest version
Have
you enabled the firewall on the local network on the server? If so,
turn off iptables (assuming you don’t have a publically facing SIP port) - NA

If the phones are on a different network than the phone server how are they trying to get to the phone server? Is it straight through the internet, via VPN, point to point? If through internet, what are the firewalls on each end?

It sounds like either it’s not pulling the config properly or it simply can’t communicate with the phone server. I think cynjut is correct, I would start by either tailing the tftp logs to see if the phones are even getting to the tftp server. Also I would run asterisk -rvvvv on the the phone server to see if asterisk shows the phones attempting to connect to the server. If nothing shows up, then their requests to register with the phone server are not getting there.

Also, maybe take one phone and forget about TFTP, just manually configure it. If going through the internet to the phone server, be sure to turn on NAT and maybe use stun server.

They are on different VLANs, thats it.

Phones are reachng the TFTD server, confirmed and pulling the correct dialplan, SEP.cnf.xml files.

asterisk -rvvvvv doesnt show any registration attempts, though

TCPdump does show packets coming in.

Is ths something to do with 9.4 FW? i read it has issues with UDP SIP?

It sounds like you are trying to connect the 7945 phones over your LAN, through your local firewall, to a server outside your local network behind another firewall. I’m not sure the CISCO SIP image supports NAT and/or STUN, and without a solid understanding of that, it’s going to be a tough slog.

If that’s the case, I’m going to guess that a firewall is in your way, but since we’re left with guessing how your network is set up, I’m going to defer to someone that can read your mind.

When you want to provide some details, I’m sure someone will provide some suggestions.

Nope, there is NO internal FW. We have disabled NAT both on phone and Asterisk. And added all local VLANs as local in the NAT config page.

Also, we tested with Cisco 7940, connected in the wink of an eye and registed with the same extension. This was done to find if we did any thing wrong on the server.

Is the extension in FreePBX set to UDP as primary but allow all? I used 7940’s a while back and I recall them defaulting to TCP not UDP. I think in SIP Settings I also had to enable TCP.

Yes, set to All-UDP Primay

I believe it may require tcpenable=yes in Asterisk Sip Settings. If the 7940 is working ok, I’m not sure if that will help, but if the phone is trying to use TCP, that is required regardless of extension setting.

So this is to be done manually, which file?

I don’t think it has to be manually. In FreePBX go to Settings - Asterisk SIP Settings - Click on ChanSIP settings.

Scroll to bottom and under “Other Sip Settings” the left box will be tcpenable and the right box will be yes.

Hi

Got this working. The trick was a minor change in the SEP file and tcpenable as above. However, conferencing doesnt work, and when trying to connect two calls, the phone says cant complete conference.

Thx

Hi

Shall apprct help here…

thx

Guys…any one? this is a show stopper!

We need more information. You need to supply the logs for the period around the attempt to conference the phone.

Please try to keep it down to a reasonable subset of the log - we don’t need thousands of lines to troubleshoot this.

The Cisco SIP image is crippled - there are lots of features that don’t work as well in SIP as they do in SCCP, which is why I usually recommend using Chan-SCCP-B. Since you are almost where you need to be, the risk of changing is high, so keep going until you find out if what you want to do is possible.

The logs will tell us where the problem is happening and what (if anything) you can do to solve the problem.

@vishalsingh Cisco 7900 series phones are 1) EOL so there is no support for them. 2) Designed to work with Cisco UC/CM. 3) All latest SIP updates to 7900 series phones are for compatibility to UC/CM. Even then they can’t even use the full advantages of UC/CM because they are so out of date.

I’ve seen numerous people have issue with very basic call features on these phones trying to run them on FreePBX, Asterisk or other PBX systems. The issue you are having with Conf. Calls is 98% a phone issue and not a FreePBX/Asterisk issue.

If this is such a show stopper, I would suggest getting phones that are current and don’t rely on a proprietary system. The Cisco SPA5xx series are inexpensive phones that work very well across numerous PBX platforms.

… or implementing a Skinny protocol stack.

I’ve worked with enough people and companies that must work on a shoestring to know that there are times when buying a few thousand dollars worth of new hardware to replace stuff that “should work” is also a show stopper.

Send your logs, let us look. If that ends up a bust, I’ll offer to work with you to get Chan-SCCP-B implemented to use the full featureset of the phones.

PFA the logs. The call is made from a Cisco 7945 with extn 1005 to softphone exten 2000, then I press conf and add another call to extn 2001. Now when both calls are active, I press the conf to create the conf but I get a message “cannot complete conf” at the Cisco phone.

Thx