Register string help

Hi guys,

I’m trying out a new SIP trunk provider.

I configured the trunk and I can make outgoing calls.

However I can’t register my DID.

The only username I have is my DID.

I tried the following register string:

DID:[email protected]

And also this:

[email protected]:password:[email protected]:port/DID

But i won’t work.

The SIP provider says they do not provide help for ASTERISK / FreePBX.
They say that their user have reported figuring it out on their own but they don’t know how.
And of course the encourage to buy their crappy equipment instead.

Let me know if you have any idea of what I should try.

useful of them!

standard convention though is normally:

user(or did in your case):[email protected]

or

user:[email protected]/user

So the provider dumped the following information… anything useful to help me configure my Trunk?

I have replaced confidential info by XXX

type            =  friend
transport       =  udp
mohinterpret    =  XXX_default
mohsuggest      =  XXX_default
subscribecontext =  XXX-local
accountcode     =  XXX
amaflags        =  default
parkinglot      =  parkinglot_procom
defaultuser     =  XXX
secret          =  XXX
host            =  dynamic
language        =  fr
t38pt_udptl     =  no
dtmfmode        =  rfc2833
encryption      =  no
avpf            =  no
force_avp       =  no
qualify         =  20000
qualifyfreq     =  300
trustrpid       =  no
sendrpid        =  pai
icesupport      =  no
nat             =  no
directmedia     =  no
disallow        =  all
allow           =  ulaw
context         =  XXX-default
cc_agent_policy =  generic
cc_monitor_policy =  generic
cc_offer_timer  =  20
setvar          =  DYNAMIC_FEATURES=atxfer#fmcxfer#blindxfer#automon#automixmon#hookflash#supervisor#conference#automonmute
setvar          =  EXTCONTEXT=XXX-default
setvar          =  TRANSFER_CONTEXT=XXX-default
setvar          =  PHONE_LANGUAGE=fr
setvar          =  AUTO_RECORDING=XXX
setvar          =  MONITOR_OPTION=wWxX
setvar          =  [email protected]_PROCOM
setvar          =  SPYGROUP=procom
call-limit      =  20
limitonpeers    =  yes
notifyringing   =  yes
notifyhold      =  yes
faxdetect       =  no

Also, I tried all those strings and I can’t get any to work.

DID:[email protected]

DID:[email protected]/DID

[email protected]:password:[email protected]:port/DID

(my DID and user are the same)

I can MAKE calls, not receive them.

What did you user for “server” ? an ip or a name?

And waht does the debug show after you “sip set debug ip SERVER” from the asterisk CLI and try to register?

+1 to Dickos suggestion. That should help you figure out any errors. If outgoing works ok, but you cant receive calls i’m wondering if it may be more of a problem with incoming routes… I reckon along side debugging, you should set your trunk up as basically as possible, and create a very simple incoming route that captures any CID / DID and forwards to one extension… once that is working, start building complexity from there.

these basic settings should work on most SIP providers in the trunk:
in Outoing:

host=<Sip provider>
username=<Your Sip provider user>
secret=<Your sip provider password>
type=friend
nat=yes << change that to no if the server is directly connected to the net.
insecure=invite
qualify=yes

leave incoming blank

register string:

<sip user>:<sip password>@<sip server>/<sip user> or <sip user>:<sip password>@<sip server>

Then delete all your incoming routes, and create a new one ANY DID/CID and send to one of your extensions. Then as dicko suggested use sip set debug ip from asterisk CLI… If that doesn’t give you any useful info… you could also try core set verbose 10 which will announce everything that happens in asterisk :smile:

HTH

Mike.

Alright I found these lines, which I think my help diagnose the problem :smile:

[2015-06-08 11:31:24] WARNING[1834][C-0000088c]: chan_sip.c:16491 check_auth: username mismatch, have <Test-New-SIP-Trunk>, digest has <XXX>
[2015-06-08 11:31:24] NOTICE[1834][C-0000088c]: chan_sip.c:25611 handle_request_invite: Failed to authenticate device "Test-Call" <sip:[email protected]>;tag=as530d88c6 

Where XXX is my DID and YYY is the SIP server IP.

I think this might means that I have a problem with my authentication?