Redial from Voicemail


(United States) #1

Is there any way to dial a number from visual voicemail on S505? I can’t find any settings or options to allow this.


(Franck Danard) #2

Hi
Sorry I don’t know what you mean.
Can you tell us more?


(United States) #3

Hi Frank!

Sure. What I mean is when in the Voicemail app on the Sangoma S505, I want to be able to directly redial the number that left the voicemail (that is if there is a number sent over CID). Just like when you get a voicemail on a cell phone and have visual voicemail service, you can dial directly from the voicemail app.

When I’m closed, my IVR sends calls directly to voicemail so there is no call history for that number to dial from. I have to write down the number and manually dial it. I hope this makes more sense. If not, I can elaborate more.

Thanks!


(Franck Danard) #4

Ah ok.
Yes, Sorry
Press on Call back. button.


(Franck Danard) #5

Select your message, and press Callback button.


(United States) #6

I don’t see a callback button or option when viewing the message. I’ve tried to search for this but I’m afraid I may be looking for the wrong keywords? Could you point me in the direction to set this up on my phone? I appreciate your time!


(Franck Danard) #7

Like this without arrow.
Here 200 called 201 leaving a message.


(United States) #8

Ahhh! I don’t have that option. Exit, Back, Play, More --> Delete, Forward, this box is blank, Exit

Just to clarify, I am trying to dial external numbers, not internal extensions. The numbers are formatted +18085551212. I hope this helps!


(Franck Danard) #9

Whatever internal or external call, it should work.
I made a test a few minutes ago, no issue.

Please, make sure your system (O.S & FreePBX) is up to date. Check your config (user manager privileges, phone apps, and voicemail settings).

Maybe there’s some module pretty old.


(United States) #10

Thank you for your time! Everything is up to date. Most settings are defaults, no special permissions have been changed. I’m the only one using the phone system with 2 phones. Is there a specific setting I should be looking at that enables or disables this feature? I’ve tried to factory reset the phone but it makes no difference.


(Lorne Gaetz) #11

Phone Apps options could differ slightly between phone models and manufacturers. I’m sure Franck is testing with an S series Sangoma phone.


(United States) #12

I’m using all Sangoma phones, 1 S505 and 1 S305. The S305 keeps locking up so its disconnected for now.

Is there a specific setting that could enable or disable this Call Back option to not show in the Visual Voicemail app? If I could find where this setting is, maybe this would give a better path to troubleshoot?


(Dave Burgess) #13

I don’t know if this has anything to do with that, but remember that the number you are about to redial has to make it out of your PBX, so it’s important to make sure that you are normalizing the caller ID number to one you can “one click” back. For example, one of my providers always put the “+1” on my incoming calls, and my outgoing provider says “No” when they see that. I have to use the “from…e184…” inbound context, mangled to meet my specific needs, to put everything in the format my CRM and outbound provider are both expecting.

Like I said, it probably has nothing to do with what you’re seeing, but it might help you later on if you run into this issue.


(United States) #14

Hi Dave,

I’m not sure if that’s related. I’m not seeing the Call Back option in the visual voicemail phone app. Sangoma S505. The box it should occupy is empty and I’m not sure where to even look for this setting. I’ve just about looked in every setting and nothing seems off or related to my issue (FreePBX and phone).


(United States) #15

Side note, I cannot test to see if it works with an internal extension because the S305 keeps locking up. I’ve just about had it with that phone. That’s a problem for a different post.


#16

So leave yourself a voicemail from the S505, or use a softphone, mobile SIP app, old ATA, etc.


(United States) #17

Update: I dialed the extension from the same extension and the Call Back option is there. It does not show up any other way. So this narrows it down. What settings can I look at that would cause this restriction?


#18

I’m guessing that the phone doesn’t like the +, either because of a firmware limitation, or because the phone dial plan doesn’t include it.

If your trunk Context is from-trunk or from-pstn, changing it to from-pstn-e164-us will strip the +1 on incoming calls, which I hope will fix the issue. However, if you are presently using from-pstn-toheader, there is no built-in context that will do both. Make a copy of the from-pstn-toheader context and put a modified version into extensions_custom.conf like this:

[from-mytrunk]
exten =>  _.,1,NoOp(Attempting to extract DID from SIP To header)
exten =>  _.,n,gotoif($["${CHANNEL(channeltype)}"="SIP"]?SIP)
exten =>  _.,n,gotoif($["${CHANNEL(channeltype)}"="PJSIP"]?PJSIP)
exten =>  _.,n,NoOp(Unable to determine SIP channel type)
exten =>  _.,n,goto(from-pstn-e164-us,${EXTEN},1))
exten =>  _.,n(SIP),Goto(from-pstn-e164-us,${CUT(CUT(SIP_HEADER(To),@,1),:,2)},1)
exten =>  _.,n(PJSIP),Goto(from-pstn-e164-us,${CUT(CUT(PJSIP_HEADER(read,To),@,1),:,2)},1)

Then set Context for your trunk to from-mytrunk and test.


(United States) #19

Hey Stewart1,

Thanks for the info. I’m right there with you on the “+” causing the issue. I’ll be honest, I’m not exactly sure what I’m looking at in your post. I just want to be sure I’m understanding things correctly. Would I need to look at how Context works? I think I saw something in the Wiki about removing the + from numbers. At this point, all of the settings are blending together haha.

I went ahead and changed the Context to your suggestion and works. Call Back is now showing up in the options for voicemails.

Thank you all for your time and help. I really appreciate it!!! I knew it was something silly causing the issue. I just didn’t know what to look for or where to start. I’ll report back if there are any further issues related to this.


(Lorne Gaetz) #20

I would consider numbers with a leading + character to be valid dial strings. This should probably be escalated for a fix. Please open a commercial module support ticket with your findings.
https://wiki.freepbx.org/display/FPAS/How+To+Open+A+Support+Ticket