Recordings and DTMF good, but no voice on incoming rasPBX calls


Iam trying out FreePBX on a raspberry Pi with rasPBX.

I am connected through a dlink router and high-speed cable modem with no port restrictions.

Currently I have the Freepbx in the DMZ and I’ve tried forwarding ports.

Here’s what’s happening: if I call out to a regular line from a sip extension, all is good.

If I call in to the system from a landline, or call from sip to sip, I have no voice in either direction. DTMF works and when I put a call on hold, the caller hears the on hold music, but no voice.

I’ve tried changing NAT settings (not saying I’ve done it right, yet) but I can not get this to change.

Any ideas?

thank you very much,


So it seems the issue was my Codecs… My VOIP provider settings showed “allow = g729,ulaw”. I know that you have to pay for the g729 coded (which I haven’t, yet, but don’t mind doing) but since it allowed both and my SIP settings had multiple codec’s checked, I just assumed the system would utilize the one that is compatible upon connecting.

Well I was obviously wrong… when looking at the logs, I was seeing Warnings all over about problems transcoding g729 into ulaw and vise-versa.

I changed my trunk settings to just “allow=ulaw” and I unchecked g729 in Sip Settings… that seemed to do the trick. (not sure if I needed to do it in the Trunk settings, as this alone did not help, or just check box in SIP settings would have worked, too.) In any event, ulaw on it’s own seems to be what works.

I will look into getting G729 working soon as I believe it uses a lot less bandwidth.