Recording not stopping for a agent

I have a situation where in the in Inbound route I have call recording set to yes,
The inbound route eventually goes to a IVR with a route to queue. The queue also has the recording set to yet.
The call went to an agent that has recording on Inbound extens & direct calls are set to yes.

The agent pressed *11 (My feature code defined is custom)

In the logs I managed to grab the following at the time
== MixMonitor close filestream (mixed)

== MixMonitor close filestream (mixed)

== End MixMonitor Recording Local/[email protected];2

== End MixMonitor Recording Local/[email protected];2

– Executing [[email protected]:3] NoOp("PJSIP/32606-0000e0c0", "ONETOUCH_REC_SCRIPT_STATUS: [RECORDING_STOPPED]") in new stack

– Executing [[email protected]:3] NoOp("PJSIP/32606-0000e0c0", "ONETOUCH_REC_SCRIPT_STATUS: [RECORDING_STOPPED]") in new stack

– Executing [[email protected]:4] NoOp("PJSIP/32606-0000e0c0", "REC_STATUS: [STOPPED]") in new stack

– Executing [[email protected]:4] NoOp("PJSIP/32606-0000e0c0", "REC_STATUS: [STOPPED]") in new stack

– Executing [[email protected]:5] GotoIf("PJSIP/32606-0000e0c0", "0?denied") in new stack

– Executing [[email protected]:5] GotoIf("PJSIP/32606-0000e0c0", "0?denied") in new stack

– Executing [[email protected]:6] ExecIf("PJSIP/32606-0000e0c0", "1?Playback(beep&beep)") in new stack

– Executing [[email protected]:6] ExecIf("PJSIP/32606-0000e0c0", "1?Playback(beep&beep)") in new stack

– <PJSIP/32606-0000e0c0> Playing ‘beep.ulaw’ (language ‘en’)

The issue is the recording didn’t stop but logs don’t show it being dropped

Has anyone encountered this.

That you have duplicate “logger’s” writing to console/full suggests you have a ‘legacy’ system, fix that first perhaps.

Having done that post a more complete log from /var/log/asterisk/full that isolates the whole call from start to end , (use pastebin for better formatting and grep out the almost unique C-nnnnnnn bit)

Where would I find a legacy system flag?

In your memory ? :slight_smile:

How and when did you originally install your system ?

So this was rebuilt about a year ago. I’ve sleept since then.

In he logger I have console & full logs on.

In your /etc/asterisk/logger_logfiles*.conf files you have duplicate defines. likely the custom one.

Here is what I have.

cat /etc/asterisk/logger_logfiles_*
;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. ;
;--------------------------------------------------------------------------------;
; For information on adding additional paramaters to this file, please visit the ;
; FreePBX.org wiki page, or ask on IRC. This file was created by the new FreePBX ;
; BMO - Big Module Object. Any similarity in naming with BMO from Adventure Time ;
; is totally deliberate. ;
;--------------------------------------------------------------------------------;
console => debug,error,notice,verbose,warning
full => debug,error,notice,warning
; output notices, warnings and errors to the console
console => notice,warning,error

; output security messages to the file named “security”
security => security

; output notices, warnings and errors to the the file named “messages”
messages => notice,warning,erro

You have two entries for ‘console’. You prob want to remove the one from the *custom.conf file.

Thanks…!!!

So this is the fail repeat steps.

On my extension I have my outbound external call recording set to yes.
I make a call from my extension to a external number.
Then I transfer the call to queue and the call recording setting is to never.
The call keeps on recording.

How would I have the call not record when its transferred to the queue?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.