Recording format please?

Greetings and salutations,

I have set up call recording with “ulaw” format, and recordings do have a .ulaw extension, but I can’t play them back, with ulaw settings on CoolEdit I can here the audio play very fast, I can’t make out the words.

What’s the proper way to play these back? What is there REAL format, since it’s obviously NOT ulaw?

Generally, is there a utility that can identify the format of an audio file?


Blame Cooledit not the format, it is in fact ulaw, just your expensive windoze software doesn’t speak it properly :slight_smile: . you can use sox to convert the ulaw file to something it does or just use linux.

Well, audacity doesn’t recognize it either…

I used “sox file.ulaw -r 8000 -c 1 -A file1.ulaw”

…to convert it to A-law and got an error about a missing RIFF header.

You’re preaching to a Linux fanatic here… :wink:

-t raw -e mu-law

No, for sox version 12.18 the option is -U or -A for u-law and a-law.

The -t raw option was accepted but didn’t help, the error remains about a missing RIFF header.

mulaw and alaw are headerless as you probably well know. Sorry, I can’t help you further, I use debian where my sox is 14.4.0 and IWFM.

I also tried what you suggested on a system that has sox 14.2 and it still didn’t work, with the same error.

Oh well, I’m sure you’ll work it out sooner or later :slight_smile:

maybe you will have better luck with the inbuilt asterisk file convert function.

rasterisk -x ‘help file convert’

I just tried it, using .wav and .WAV as output. The playback is noiseless but way too fast, about 2x.

There is a SoX for that also, tempo. But I’ve never experienced any of what you say.

On the net I see that this “too fast playback” issue is known and has been dealt with as a bug in the asterisk development arena.

I have experienced the 2x thing, not sure how I did it. Somehow the sample must be slower or less of it to cause.

Audacity works fine for me.