Recorded Call Issues - MixMonitor not reading file format (Ast 1.8)

FreePBX Disto 1.818.210.58-1
FreePBX 2.10
Asterisk Ver.

Greetings Everyone,

I recently migrated from an old Trixbox server and nearly everything is tested and working. That said, the there is a configuration issue that is stopping me from recording most calls. See the following log:

== Begin MixMonitor Recording DAHDI/1-1
[2012-12-27 16:30:33] WARNING[16698]: file.c:1178 ast_writefile: No such format ''
[2012-12-27 16:30:33] ERROR[16698]: app_mixmonitor.c:334 mixmonitor_thread: Cannot open /var/spool/asterisk/monitor/2012/12/27/xxxxxxxxxxxxxxxxxxxxxxxx.

(xxxxxxxxxxxxxxxxxxxxxxxx placed by me but note the lack of file extension.)

I see that there is some forum activity where the extension was filled with garbage characters, but I couldn’t see anything about it being blank.

After some digging, I believe the problem seems to be no statement declaring that MIXMON_FORMAT = wav.

I’m also guessing that this value is set by “Call recording format” from the FreePBX-Settings-General Settings page. If I attempt to change the value on that page from “WAV”, to anything else, it won’t save.

As a trial, I placed the line: MIXMON_FORMAT = wav in extensions_custom.conf and reloaded. All was working great for about a day, now for some reason it started having the same error.

Is that value saved in the DB somewhere? Any thoughts?


I spoke incorrectly, regarding where I had placed “MIXMON_FORMAT = wav” I must have placed it directly in extensions_additional.conf and reloaded… Which is why it had been working until it was overwritten by FreePBX.

I since noticed the /etc/asterisk/globals_custom.conf file and added the line there. Now after a reload, recording is operating correctly.

However, my question still remains: Why was this not working in the first place, and is this just a symptom of a larger problem in my configuration?

Thanks for any input.