Record calls on demand not work

Hello guys,

I have installed AsteriskNOW 3.0
Freepbx 2.11.0.1

I can not get the system to record on demand when I press * 1

I configured the properties of the extension:

External Inbound Calls?
do not Care
 
External Outbound Calls?
do not Care
 
Internal Inbound Calls?
do not Care

Internal Outbound Calls?
do not Care

On Demand Recording
Enable

When on a call i press * 1 the following appears in the console:

-- Feature Found: apprecord exten: apprecord -- Executing [[email protected]:1] System("SIP/215-0000001d", "/var/lib/asterisk/bin/one_touch_record.php SIP/215-0000001d") in new stack -- Executing [[email protected]:2] MacroExit("SIP/215-0000001d", "") in new stack

I do not hear any beep and the recording does not happen.

For test i set the extension settings to record forever, then works, i can view the recordings just right.
But on demand not work. :frowning:

What might be happening?

thank you

Not sure exactly which version of Asterisk is included with AsteriskNOW 3.0 but I have a problem with a system running Asterisk 1.8 which is sort of similar but the problem with that one is that it records on demand fine but the file name format does correspond to any useful format the can be picked up in the user portal. Have a look in /var/spool/asterisk/monitor and see if you have any files starting “auto-”.

Had seen on the forums this problem with the file name. This is not the case, I had already checked this folder and the files are not even created.

The Asterisk version is 11.4.0

Anyone else?

I also have a new freepbx 2.11.0.1 along with Asterisk 10. I don’t get a beep when I press *1. It is recording I checked the files like Lee said, (THANKS!), but without the feedback of the beep my users aren’t happy like the old system we were on (old trixbox).

The extensions are set On Demand Recording enabled. - the settings like CyberVerme

Any other Ideas?

If you think this is a bug then by all means feel free to report it.