Recent multicast paging feedback/noise with P330 and Paging Pro

We have a FreePBX 16 (latest) using P330 phones and Paging Pro to do a simple multicast “All-Page” on our company LAN. Basically setup a paging group (8000) with no members and set it to use multicast only on
This has has been working almost year but this week it began acting oddly, giving strange feedback on the announce tone with the audio repeating and very garbled. It is like the P330 set doing the paging is playing and feeding back on its own audio.
The only recent changes where the usual module updates (including a firmware update to the P330) which I rolled back but the issue persists.
The issue also does not occur if we use the P330’s new ability to generate multicast pages (ie: setup the multicast broadcast in the EPM for the P330 and bypass paging pro) although the interface is a bit clunky and does not give us announce tones, etc.
It appears to be an issue in the P330 but it is odd that it only gives the issue when we use multicast through Paging Pro. Out of ideas.

Thanks for ay input.

I don’t know what Paging Pro is doing or how your setup works, so I’m just going to take a stab at things…

The P330 has two basic kinds of multicast behaviors:

To configure listener, it’s setup like this:

<?xml version="1.0" ?>
        <listener id="1" name="SomePage" extension="123" addr="" port="32000" priority="1" interrupt_calls="0"/>
        <listener id="2" name="All Page" extension="456" addr="" port="32000" priority="2" interrupt_calls="1"/>

What’s happening in there is…you’re setting an identifier, giving the listener a name (so when it’s triggered that’s what’ll show on the phone’s screen), optionally defining an extension (if the phone’s dialed an extension matching this and it’s in a call then it’ll ignore audio coming in for this listener…hint), setting an address for the listener, a port for the listener, a priority for the listener (priority matters for precedence), and defining the behavior to use if the phone’s already on a call.

The other type is a broadcast, defined like:

<?xml version="1.0" ?>
        <broadcast id="1" name="My Paging Group" addr="" port="32000" codec="PCMU" />

There, you’re defining an id, a name to display within the multicast broadcast app, the address to broadcast to, the port to broadcast to, and the codec to use when broadcasting. Simpler.


I’d hazard that if your phone is in some kind of audio loop, that you’re dialing some server extension that’s then doing a multicast broadcast directly from Asterisk, or it’s unicasting to some device (Algo, etc.) that’s multicasting, and the phone has a listener also configured for that address, and the phone’s not configured to ignore (interrupt_calls=2) that listener when in-use or the exten you’re dialing isn’t the one that’s set.
Well, if the phone does a dial to Asterisk, and Asterisk then multicasts out or unicasts out to an address the phone is listening on, those two things aren’t inherently connected. That’s what the exten parameter is for, and that’s what interrupt_calls=2 can handle.

But, this is all just a guess, and I’ll go back to lurking now…

Thanks for the input but what you describe is what I switched to as a workaround - using the P330’s recently added built-in multicast broadcasting ability. It didn’t have the broadcast feature (just listener) when I started so I bought Page Pro and setup page zone 8000 as described to use multicasting which is the part that recently stopped working.
Note for the P330 setup in my case I only have one multicast address (all-page) so each phone both listens and broadcasts on the same address which seems to work fine.
The issue seems to be when the asterisk server itself generates the multicast (via page pro zone 8000), the phone appears to hearing its own page and feeding back which it never did before.

and how is this listener for that address configured in the phone’s config file?

1 Like

Thanks for the direction - I had a look at the P330’s multicast configuration for the listeners and finally clued in that the new “interrupt calls” setting was set to 0. Since that setting did not exist before I assume that is the default, problem is that is a terrible default as it plays the audio received over the call which was exactly what I was seeing, feedback. Changed it to 2 and all is working again. That also explains why reverting firmware and module versions did not help, the issue was in the “upgraded” configuration.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.