Receive sip response 406 "not acceptable" back from IP


(Superdigi) #1

when outbound route 1st trunk call out to cell phone with no pickpup or reject the call, my pbx will automatic call again with another trunk. how can we disable or custom this situation?


(Dave Burgess) #2

This sounds like a case where the response coming back from the provider or the phone isn’t accurate, and Asterisk (not FreePBX, but Asterisk) is processing the call because the call “failed”. The call isn’t ‘not acceptable’ (the call would go through if the phone wasn’t busy), it’s ‘busy’. Since the provider is saying “Your call cannot be processed because your asking for something we disapprove of”, the obvious response from Asterisk is to say “Oof, sorry, let me try another trunk, didn’t mean to bother you.”

The problem is that even if you were to stop the call from dropping onto the next trunk, the response you’d get at the PBX (to your local extension) would be something like “The number you dialed said you suck” (obviously, in spirit) which wouldn’t be true - the phone is busy and you should get a busy signal.

Asterisk is open source, so you could look through the code and find the ‘406’ handler and change the behavior on your instance, but that’s really not a great idea. Another possibility is to turn off the “continue to next trunk” on the trunk definitions. Once again, I’m not sure that would be a great idea either.

If you feel like tilting at windmills, you could contact the ITSP you are using and find out why they are sending a 406 to you. They might have some insight into the issue.


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.