FreePBX | Register | Issues | Wiki | Portal | Support

Random DTMF issues - Carrier says PBX issue


(Sentinel) #1

I am guessing this is a provider issue but the provider is saying it’s a PBX issue. Incoming DTMF is sending the wrong dial tones for all numbers on my PBX. I have about 8. My sip settings are as follows:

disallow=all
type=friend
secret=username
username=password
;dtmfmode=rfc2833
dtmfmode=info
context=from-trunk
canreinvite=no
allow=ulaw
insecure=port,invite
host=x.x.x.x (real IP is here)

I have tried DTMF is auto, info, rfc2833 with all the same results. A test call log shows this after dialing 132 at the IVR:

Full log here: Log Files


(Tom Ray) #2

This debug is over 50K of garbage. You have calls that are unrelated, you have at least two restarts/reloads where you’ve restarted/reloaded Asterisk/FreePBX. There are calls to voicemail and calls of hackers trying to get through your system. No one will be able to make sense of this.

You need to do a debug that is 100% for that call alone. Don’t pull from the logs actually open the Asterisk Console and do the call and take the LIVE output so you’re not just grabbing everything under the sun and it can be looked at properly.


(Sentinel) #3

How do you filter the log that way?


(Tom Ray) #4

asterisk -rvvvvvvvvvvv <-- This puts you in the Asterisk Console. You then make a call. It will display output. Once you’re done with the call paste it.


(Lorne Gaetz) #5

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs


(Sentinel) #6

Perfect. I should have that In a bit


(Sentinel) #7

First test call to number, then dialed extension 132 and got some other extension. Second test call, same DID but extension 116 and got a random extension as well. This was on incoming sip set to rfc2833.

Dialing another DID, the IVR is totally ignored when dialing extension 121. It appears that it’s not sending the correct digits?

Trace at Ext 132 from DID

Trace at Ext 116 Same DID

Trace on 2nd DID where IVR is ignored


#8

You need to look at your logs, your dtmf mode and question siplogic, there is no 123 coming through there is

.
.
.
[2019-01-03 22:45:29] DTMF[12993][C-00000046]: channel.c:4126 __ast_read: DTMF end passthrough ‘2’ on SIP/siplogic-00000045
– Executing [11133222@ivr-2:1] GotoIf(“SIP/siplogic-00000045”, “1?i,1”) in new stack

which wont work. fix that with siplogic before you go anwhere . . .

further to that you also posted
– Called PJSIP/116/sip:116@24.106.230.230:13737
== Using SIP RTP Audio TOS bits 184
== Using SIP RTP Audio TOS bits 184 in TCLASS field.
== Using SIP RTP Audio CoS mark 5
– Connected line update to SIP/siplogic-00000048 prevented.
– PJSIP/116-00000075 is ringing
– PJSIP/116-00000075 is ringing
– Nobody picked up in 15000 ms

so in that case "answer the bloody phone when it’s ringing :wink: "


(Sentinel) #9

what are you saying won’t work? What needs changed?


#10

Pretty well it’s the agreement between you and you provider as to how to handle DTMF , very few VSP’s now don’t do rfc2833 properly. If they can’t then perhaps try another one


(Sentinel) #11

I have tried auto, info, rfc2833, inband - all same result. They are telling me its a PBX issue and everything is fine on their end.


#12

Does your system work with other VSP’s ?


(Sentinel) #13

it’s freepbx, so I’m not sure what you mean by system.


#14

Well FreePBX works pretty well for everyone else but you.

There is an old philosophical concept “reductio ad absurdum”

If your provider doesn’t work, add another one, if that doesn’t work , chances are you are doing something wrong., keep on doing the adding bit or changing your own method . . .


(Sentinel) #15

I could test another provider with a DID and setup a test trunk.


#16

There you go :slight_smile: , reductio in action . . .


#17

We’ve seen similar issues with some PRI providers; the AdTran doesn’t provide a long enough DTMF for the system to always pick it up, so we’d see randomly dropped/missed key presses from incoming callers. It took MONTHS of working with the provider before they added this to the AdTran config and all the problems went away:

ip rtp dtmf-relay min-duration 250

This might not be exactly your problem, but might also point you in the right direction.


(Sentinel) #18

Interesting. I’ll pass it on


#19

If you don’t mind, please post back the result…getting through this was a significant PITA and we dealt with a lot of “It’s not us, it’s you” from the provider before we got to this…saving anyone else the hassle is good karma.


(Sentinel) #20

I tried another carrier with same result. We have a case open with Sangoma to help push