Queues with static agent and linear ring strategy

Hi2all.
I’m trying to get working queues, with external phone numbers as static agents.
I choose ring strategy linear an expect that phone willbe ringing one by one.

But phones ring together:(

I change external phone numbers on internal extensions, but they ringing together too:(

Elastix version 1.6.2-1, Freepbx is up to date(2.7.0.2).
I had already reinstall queues module. But problem still exists.

What additional info you need to help me find the root of problem?

lot of thanks:)

The linear strategy is new to FreePBX and only on 1.6+ in Asterisk.

For starters check what ring strategy Asterisk thinks it is in. I believe you can type:

queue show nnn

and see if it says it is in a linear strategy. If not, then check the queues_additional.conf and see if we are setting it right or if there is a typo or something.

If you trace it down to a FreePBX bug, feel free to file a bug in the tracker.

It stopped working entirely with the last update. I also have mine set to linear in FreePBX but Asterisk shows it is “ringall”

sip*CLI> queue show 2200
2200 has 1 calls (max unlimited) in ‘ringall’ strategy (0s holdtime), W:0, C:0, A:0, SL:0.0% within 300s
Members:
Local/[email protected]/n with penalty 1 (Not in use) has taken no calls yet
Local/[email protected]/n (Not in use) has taken no calls yet
Local/[email protected]/n with penalty 2 (Not in use) has taken no calls yet
Callers:
1. SIP/sip.broadvoice.com_outgoing-0000135e (wait: 0:28, prio: 0)

I am using:
FreePBX 2.7.0.2
Asterisk 1.4.29.1

I know you say it is only supported in Asterisk 1.6+, but Linear DID work on 1.4.29.1 prior to some recent FreePBX updates. After one of the updates (sorry I cannot remember which one), it started to send calls to recipients only to tell them that someone had already picked it up, yet they had picked up on the first ring and the call was dedicated to just their extension for 30 seconds.

First the “ringall” setting needs to be rectified in order to test it again to send call examples regarding the queue falsely telling agents that another agent has already accepted the call.

Regarding my post above, here is Queue 2200’s setting in queues_additional.conf

[2200]
announce-frequency=15
announce-holdtime=yes
autofill=no
eventmemberstatus=no
eventwhencalled=no
joinempty=yes
leavewhenempty=no
maxlen=0
monitor-type=mixmonitor
monitor-format=wav
music=WelcomeOperator
periodic-announce-frequency=0
queue-callswaiting=queue-callswaiting
queue-thankyou=queue-thankyou
queue-thereare=queue-thereare
queue-youarenext=queue-youarenext
reportholdtime=yes
retry=3
ringinuse=yes
servicelevel=300
strategy=linear
timeout=30
weight=0
wrapuptime=0
context=ivr-3
dynmemberonly=yes
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0

equality4xy,

I don’t know what is going on with your other issues but I will not address them here. Please create a new thread if you need people to help you as I do not want to hijack lobster40’s thread.

I will clarify one thing though, here are all the strategies straight from the latest Asterisk source code, note there is no linear strategy which would imply the reason for the issues you are seeing are simply related to Asterisk probably defaults to ringall if you put in a strategy that it does not understand.

static struct strategy {
  int strategy;
  char *name;
} strategies[] = {
  { QUEUE_STRATEGY_RINGALL, "ringall" },
  { QUEUE_STRATEGY_ROUNDROBIN, "roundrobin" },
  { QUEUE_STRATEGY_LEASTRECENT, "leastrecent" },
  { QUEUE_STRATEGY_FEWESTCALLS, "fewestcalls" },
  { QUEUE_STRATEGY_RANDOM, "random" },
  { QUEUE_STRATEGY_RRMEMORY, "rrmemory" },
};

But back to lobster40 who is running 1.6.2 and where there should be a linear strategy, what do you get that would be equivalent to equality4xy’s example where you can see asterisk believes it is ringall:

sip*CLI> queue show 2200
2200 has 1 calls (max unlimited) in 'ringall' strategy (0s holdtime), W:0, C:0, A:0, SL:0.0% within 300s

in his case, he tried to set it to linear “properly”:

strategy=linear

In his case, the behavior is correct as there is no linear strategy (unless there is some non-standard patch applied which I have not investigated), but in your case, 1.6.2 should have a linear strategy.

I think you meant to say “ringall” not “ringgroup”

I didn’t mean to hijack this with my own issues, in fact I am not going to try to fix them, I will simply build a new machine with Centos 5.4, Asterisk 1.6 and FreePBX 2.6

equality4xy,

thanks for the correction, I fixed it above.

I also was not implying you were hijacking the thread. Part of your post was completely related which is why I commented on it. I didn’t want to go off and speculate on your other issue and have ME hijack it, thus my comment that I don’t want ME to hijack the thread:-)

oops.
I didnt say that I use asterisk 1.6.
I sad that I use Elastix 1.6 (which works with Asterisk 1.4)

I reinstall Elastix and perfrom elastix update, freepbx update and asterisk update.

Now I have
elastix 1.6.12
freepbx 2.7
asterisk 1.4.30

I can see linear strategy for queues- but it doesnot work.

*cli> queues show default
-ring strategy ringall

Created queue with strategy linear 54321

*cli> queues show 123456
-ring strategy ringall

So…can I use queues linear strategy with 1.4 asterisk? Or it function is restricted by * version ?

Thanks.

FreePBX should not allow linear for 1.4 but it’s possible that it is allowing you to set it.

However, unless Elastix has a patched version of app_queues.c that allows linear, as pointed out above, Asterisk 1.4 does not support that strategy.

The log message may think it created a queue with linear because it may not be sanitized at the time of that message, but you can see from the “queues show” command that the authoritative state of the queue is ringall.