Queues, blind transfer, no voicemail

So, the logic is as follows: A call comes into the queue and the queue agent needs to blind transfer that queue call to another extension. When the call is transferred, it will ring and at the timeout point (when it should fail to voicemail) it just goes silent and hangs up.

I found out that editing out the 4 lines that reference BLKVM lets voicemail work, but as you know anytime you use the freepbx page, it’ll overwrite these settings.

Is there a reason why blind transfers from a queue blocks voicemail? Is there a way in freepbx to stop that? Thanks for any input :slight_smile:

[ext-queues]
include => ext-queues-custom
exten => 7000,1,Answer
;exten => 7000,n,Set(__BLKVM_OVERRIDE=BLKVM/${EXTEN}/${CHANNEL})
;exten => 7000,n,Set(__BLKVM_BASE=${EXTEN})
;exten => 7000,n,Set(DB(${BLKVM_OVERRIDE})=TRUE)
;exten => 7000,n,Set(_DIAL_OPTIONS=${DIAL_OPTIONS}M(auto-blkvm))
exten => 7000,n,Set(__NODEST=${EXTEN})
exten => 7000,n,GotoIf($["${CONTEXT}"=“from-internal”]?USERCID:SETCID)
exten => 7000,n(USERCID),Macro(user-callerid,)
exten => 7000,n(SETCID),Set(CALLERID(name)=${CALLERIDNAME})
exten => 7000,n,Set(MONITOR_FILENAME=/var/spool/asterisk/monitor/q${EXTEN}-${TIM
ESTAMP}-${UNIQUEID})
exten => 7000,n,Queue(7000|tr|||30)
exten => 7000,n,dbDel(${BLKVM_OVERRIDE})
exten => 7000,n,Set(__NODEST=)
exten => 7000,n,Goto(ext-queues,8888,1)
exten => 7000*,1,Macro(agent-add,7000,1234)
exten => 7000**,1,Macro(agent-del,7000,7000)

[quote=“p_lindheimer”]my suggestion is to do an svn pull of freepbx 2.2.1 tag (so that you get exactly what trixbox should be loading. Then compare extensions.conf in there with what is on your system to see if it is different. But - before going through that much trouble, do the following. Do a comparison against the tarball that the trixbox package manager should have downloaded. I’m guessing they install it under /usr/src/freepbx - so go there and look under amp_conf/astetc for extensions.conf and compare against what you have in /etc/asterisk. If there is a difference there - that’s a big clue. If not - you may need to go do what I mentioned above.

Or … just go reinstall it without the package manager and see if it makes a difference.[/quote]

Interesting:

[[email protected] astetc]# diff extensions.conf /etc/asterisk/extensions.conf
309,310c309,310
< exten => s,n(theend),Wait(5)
< exten => s,n,Hangup

;exten => s,n(theend),Wait(5)
;exten => s,n,Hangup
952c952
< [macro-auto-blkvm]


;[macro-auto-blkvm]

You think either of those two differences make a difference? :shock:

so why are they different? They should be the same.

macro-auto-blkvm:

that’s the macro that releases the flag upon answering a call, so that subsequent transfers are not blocked form voicemail.

[quote=“p_lindheimer”]so why are they different? They should be the same.

macro-auto-blkvm:

that’s the macro that releases the flag upon answering a call, so that subsequent transfers are not blocked form voicemail.[/quote]

I honestly have no idea. There are other people who administered this box before-hand. It’s supposed to be a brand new TB 2.2 install, but there’s a plethora of problems with it already.

well I hope that fixes your issue. If it does, and you feel inclined, there’s always a nice ‘donate’ button up on the left of the main freepbx.org page :smiley:

That doesn’t sound bad to me :slight_smile:

Hm, so it seems like making extensions.conf default didn’t help. I notice this is the output in /var/log/messages/full for a blind transfer:

May 17 14:38:41 VERBOSE[11690] logger.c: – Executing Macro(“Zap/8-1”, “dial|15|TtrM(auto-blkvm)|6370”
) in new stack

There’s never a need to block voicemail with this phone system… is there something in extensions.conf that can be commended out to prevent auto-blkvm?

auto-blkvm does not ‘block’ voicemail. It is a macro that - upon the phone call being answered, it clears a flag so the system knows that the call has been aswered in case there is a subsequent transfer. If it comes in from a queue, the flag is set and the voicemail macro sees that so it does not answer the call. Once answered though - you don’t want a subsequent transfer to be blocked from going to voicemail. That is why this macro is called.

Are you using asterisk ‘agents’ (agents.conf) by any chance. If you are - they are not supported in the freepbx config and the do not necessarily operate properly.

otherwise - provide a proper cli trace of the call going to the queue, being answered, and then being transfered and the voicemail hanging up to look closer.

[quote=“p_lindheimer”]auto-blkvm does not ‘block’ voicemail. It is a macro that - upon the phone call being answered, it clears a flag so the system knows that the call has been aswered in case there is a subsequent transfer. If it comes in from a queue, the flag is set and the voicemail macro sees that so it does not answer the call. Once answered though - you don’t want a subsequent transfer to be blocked from going to voicemail. That is why this macro is called.

Are you using asterisk ‘agents’ (agents.conf) by any chance. If you are - they are not supported in the freepbx config and the do not necessarily operate properly.

otherwise - provide a proper cli trace of the call going to the queue, being answered, and then being transfered and the voicemail hanging up to look closer.[/quote]

Hm, agents.conf has this:

autologoff=15
wrapuptime=5000
ackcall=no

group=1
agent => 204,1111,Ryan C

However, I don’t see any of the other confs doing an include => agents.conf, so would that matter?

Thanks again for your help :slight_smile:

it would matter if you are putting in the agent number into the queues module with a leading ‘a’ - that would make it use agents.conf. Or post your queues_addtional.conf - that will reveal it right away.

my suggestion is to do an svn pull of freepbx 2.2.1 tag (so that you get exactly what trixbox should be loading. Then compare extensions.conf in there with what is on your system to see if it is different. But - before going through that much trouble, do the following. Do a comparison against the tarball that the trixbox package manager should have downloaded. I’m guessing they install it under /usr/src/freepbx - so go there and look under amp_conf/astetc for extensions.conf and compare against what you have in /etc/asterisk. If there is a difference there - that’s a big clue. If not - you may need to go do what I mentioned above.

Or … just go reinstall it without the package manager and see if it makes a difference.

what version of freepbx are you using?

[quote=“p_lindheimer”]what version of freepbx are you using?[/quote]I knew I forgot something.

2.2.1

should be ok then - that was a bug that was fixed up until 2.2.1-rc3. Make sure you really do have the proper extensions.conf file where the macros are that manage that issue and that you have not done anything custom that woudl break things. Once the call is answered, the ‘flag’ that blocks it from going to voicemail should get cleared and subsequent transfers should work.

Is there something specific that I should be looking for?

This freepbx installation is a clean 2.2.1 via a new TrixBox 2.2 isntall. The only way it works right now is by commenting out these lines in extensions_additional.conf (i know that it’ll get overwritten with any changes through freePBX).

;exten => 7000,n,Set(__BLKVM_OVERRIDE=BLKVM/${EXTEN}/${CHANNEL})
;exten => 7000,n,Set(__BLKVM_BASE=${EXTEN})
;exten => 7000,n,Set(DB(${BLKVM_OVERRIDE})=TRUE)
;exten => 7000,n,Set(_DIAL_OPTIONS=${DIAL_OPTIONS}M(auto-blkvm))

There’s also a lot of problems with feature codes not working… is there a “fresh” extensions.conf that I could use to replace possibly?