Queue user login invalid

I am using FreePBX 2.11 along with Asterisk 11.2.1 (the latest AsteriskNow build). I’ve put it in device and user mode. I’ve added users in the dynamic agents. When one of the agents logs in with queue*, Asterisk shows:

user name (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Invalid) has taken no calls yet

And dialing the queue from another extension does not ring to the agent.

I’ve checked the module loading per other messages and it is correct (seems that has been corrected in the FreePBX build). I’ve checked some of the other settings I’ve found, but none of them makes a difference.

Any suggestions?

Good morning, Tom.

I had some trouble getting queues working, and found that as usual, a step-by-step approach is best. Start off with empty Static Agents and Dynamic Members boxes and Restrict Dynamic Agents set to No. In that configuration, anyone and everyone should be able to log in and register themselves as agents. Try that and see if it works, and let us know.

In my case the problem was a real boneheaded move on my part… I hand-edited (as root) one of the /etc/asterisk files that said “Do not hand edit!”, just as an experiment to test a different issue, and when I restored the file to its original form it kept its root ownership so FreePBX couldn’t modify it. Like I said, a real boneheaded move. :frowning:

Eric / www.rkt-tech.com

Well, no luck, tried with a user 3000 (from device 1002) and with 1003 (from device 1003), here is the result:

7911 has 0 calls (max 10) in ‘linear’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0% within 60s
Members:
Tom Johnson (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Invalid) has taken no calls yet
Local/[email protected]/n (ringinuse enabled) (dynamic) (Not in use) has taken no calls yet
No Callers

Given what you said, wonder if I should reload and start in device/user mode before creating anything else.

I’m still pretty new at this stuff and so I’m not sure about many things… for example I don’t know what “device/user mode” is. I just dial XXX* to log in to the queue, and dial in the extension number or outside phone number of the agent and hit “#”, and it Just Works. I don’t try to specify any kind of device.

I use SIP trunks with Grandstream FXO gateway boxes… maybe if you’re using something else, you need to specify devices?

I just logged 701 in as agent for queue 401 and said “queue show” from asterisk -r and got this:

Eric Poole (Local/[email protected]/n) (dynamic) (Not in use) has taken no calls yet

Nothing in there about “from hint” or “(Invalid)”. What’s that “from hint” all about? Maybe that’s getting in the way.