Queue - Transferred call still shows in use

I am running FreePBX v2.8.03. I am using dynamic agents with local channels in a call center. I understand that there is apparently an issue with a transferred call still showing as “In Use”. I am running Asterisk It seems the way to fix this behavior is to set USEQUEUESTATE=TRUE. I am unclear whether this will work because I am using 1.6 and it apparently requires a patch which may or may not exist for 1.6. I got this information from http://www.freepbx.org/news/2010-02-26/heavy-queue-usage-in-freepbx.

Can anyone clear this up for me? I am able to fix this behavior using Asterisk 1.6 or am I screwed?


If you don’t have an actual device to associate with the member then there is little you can do.

The Local channel will remain busy, and this is the crux of why the added device information was added to Asterisk in 1.6 and actually back-ported to Asterisk 1.4 which is almost un-heard of since it really is technically a feature enhancement but solved a big enough problem that warranted the Asterisk team to allow it to be back ported.

That patch will not work without a patch that has not been ported to 1.6.

However, 2.8 will now associated the device for your state information automatically, assuming the extension does have a proper device associated with it.

If there is no device (e.g. an external number is your queue member, then neither option would help as their would be no device to provide a device state.

Thanks for your response!

So external numbers are my queue members but I do still get In use/Busy working correctly on a “queue show”. “SIP show inuse” also shows the queue members as in use. I guess this is something different.

I am using a legacy PBX (Cisco Call Manager) where all phones are registered. I then connect to FreePBX via SIP trunk for Queueing.

Everything works except that transferred queue calls are held by the transferee and their status remains In Use until the transferred call ends. Anything I can do to get transfers to release the transferee?