Queue Reports (QXACT) - No queues available for selection


I have installed a trial of the QXACT module - and when trying to generate a report i have no queues to select from.
On the freepbx queues - i have 43 queues created and available.

Have anyone encountered the same issue?
what other information is needed in order to help the debugging? as i am clueless about this module and its building blocks (more or less)



Hi John:

There is a script that sync’s queue log data to a MySQL table. If that script is not populating the table properly, you might see this. Here is a quick test, while logged in to your PBX as root, do:

select count(*) from asterisk.qxact_calls;

This will tell you if there are any data rows in the table to generate reports from.


I ran the query

| count(*) |
|        0 |
1 row in set (0.00 sec)

I guess that table in the database is not updated from my queue list.
that is why the reports cant see the queues i presume.

Yeah, that is your problem. Suggest you open a commercial module ticket.



1 Like


I am having the exact same issue. Did you manage to resolve it? If so, how?


My issue was a bit idiotic one…

My queue log file was empty - I was testing the reporting system without any records in the log.

Log path is /var/log/asterisk/queue_log.

Once I simulated incoming and outgoing calls to the queue - the queue_log started to fill up.

once there was data there… i could see the reports under the QXACT module.

Make sure /var/log/asterisk/queue_log has data in it!




It seems we are experiencing different issues because my queue log contains data.

Thank you for your reply John

When you run the query :

select count(*) from asterisk.qxact_calls;

do you have any count?

It is empty !


It seems like that is your problem.

As the module generate the reports from that table.

As Lrone Gaetz wrote on this thread :
there is a script that populating the table from the queue log file.

If your log has data in it and the table is not populated then there is probably an issue with the script or the table itself (maybe permissions issues? )

I did not get much further into troubleshooting because my own issue was solved in a much more easier way… so i cant troubleshoot the module any “deeper”… But i can say that that area might be the problematic area.

I do have one more advice for testing… - but it is not recommended or official… if you know your way around MYSQL… maybe you can try just for testing purposes… manually add some data into the table itself and see if the module then generates a report… will not solve your issue but then you will know for sure that your issue is the empty table in the DB.


I will definitely try the manual approach for troubleshooting purposes. If ever I find that the problem is only with the script populating the database, do you know what the script name is/where it resides on the system?

Again, thank you very much for your response.

I believe it is under the module code and not open for everyone.

worse case scenario, open a commercial module ticket…

For some reason, previous call logs were not imported. I have 30 days of queue_log-2017xxxxx files that I need to import. Is my only option to rename each to queue_log and run the scheduled cron job that imports data, or is there some other command to pull this data into the table for all queue log files?



Never mind! I was able to answer this question myself. I found I can run the following command to import any other queue_log files I may have:

/var/www/html/admin/modules/qxact_reports/import_queue_data.php /var/log/asterisk/queue_log-2017*

1 Like

FreePBX 13 / Asterisk 13.13.1
(Trial Qxact)


I have the same problem.
If I run this php script manually, it is OK (the data appear in Qxact reports).
But if I make new calls, they dont appear in our report again.
How can I solve this problem definitely?
Why does not the script run automatically for the data to appear in the reports?
I will wait your help.

Marcelo Henrique

The script runs every 5 minutes from a cron

I am having a similar problem. We have queue logs going to a database table. When I installed the QXACT module, I had to write a program to re-export that back to the queue_log file ready for the cron job to import.

This has been running for over a year but has recently stopped importing from queue_log.

there are no errors that I can see and as the source is encrypted, I can’t look at why its failing.

Does anyone have access to the source ? It would be obviously better to go straight from the internal queue log tables to the qxact tables but I don’t want to write rows myself in case there’s something I don’t get right.

If I can’t get this working, i need to write rows to these tables manually which will suck i think.

I have the same issue. When I check the database. It seems to have data in it. However, I see no data for queue logs. What can I do to fix the queue_log?