Queue report entries not coming after changing the Freepbx server time

Hi All,
My Freepbx server time was 4 hours prior to the current time, so I corrected the server time to present. After that call entries are not coming in the queue report. Is anyone having an idea why happened like this.

Hi @dicko @comtech
Can you help me if you have any idea about this issue.

Your ‘server time’ should always be UTC or some things will fail, how did you ‘set it’ ?

you can however change the PHP TimeZone in advanced settings

I changed by passing linux command date -s " " in CLI
Previously in sysadmin Timezone = America/newyork and phptimezone also America/newyork but server time was incorrect it was prior to 4 hours so I corrected the time.

Not a good idea for a network connected linux box :wink:

Better to use timedatectl in systemd boxes to see current status (You will need a working ntpd but that is very OS dependent)

timedatectl help
timedatectl status
timedatectl set-ntp true
timedatectl set-timezone America/New_York # Note the spelling and case !
timedatectl status