Queue remote extensions do not stop ringing

Hello everyone,

We have 1 box with the latest Freepbx and Asterisk 13.5.
We have 1 SIP provider who is also offering us virtual extensions, i.e. endpoints which connect directly to their server and which we can dial directly through specified extension numbers, such as 7501, 7601, etc.

We have set up these extensions, along with some internal extensions, as agents in a couple of queues. All extensions ring when required, however when an internal extension picks up, the “virtual” ones do not stop ringing.
We have checked the Advanced Asterisk settings and the Asterisk Dial Options is Ttr, while Asterisk Outbound Trunk Dial Options is Tt.We also tried Asterisk Dial Options as Tt, but the problem remains.

Here is the really weird thing: The first time the queue receives a call after we Apply Config, the virtual extensions stop ringing if an internal extensions picks up (i.e., the normal behaviour we are looking for).

After that, the virtual extensions keep ringing, even if the call is picked up elsewhere.

We have also tried that with 2 different queues, one with “Mark calls answered elsewhere” set to Yes and the other to No, same behaviour.

Does anyone have any idea what may be happening?

Sorry to come back to this, but it has been driving us crazy. Does anyone have any idea what may be wrong?