Queue members login via AMI

queue
Tags: #<Tag:0x00007f24c2ad8ae8>

(Fangulo) #1

Hi I’m in an internal project of the company where I work, I’m working on a web interface to login and track the time of agents, the project is very simple, I’m trying to add members to the queues using AMI on FreePBX, the syntax that I’m using to add a member is:

Action: QueueAdd
Queue: 6000
MemberName: 1000
Interface: Local/1000@from-queue/n from hint:1000@ext-local

Next step I’m doing is to type a queue show command on asterisk CLI and the output I get is:

1000 (Local/1000@from-queue/n from hint:1000@ext-local) (ringinuse enabled) (dynamic) (Not in use) has taken no calls yet

I have the extension 1000 configured as a Dynamic agent in queue 6000 settings. When the extension receives an inbound call (queue call or internal call) the status of the extension changed to IN USE on CLI but when I do an outbound call from the extension 1000 the status doesn’t change and appears Not in use, that is a problem because if an agent with an active outbound call receives an inbound call the softphone rings at the same time the active outbound call is placed.

I don’t know what is the difference between login from AMI the Dynamic Agent and login the agent with the feature code *45, I notice with the output of queue show that the member of the queue appears exactly the same in the both scenarios, but only if I log the agent with the feature code the problems disappear, the extension appears IN USE doing outbound calls.

The other problem that I found is related to CDR report, if I use my method using AMI the activity of calls on the CDR report of FreePBX of the inbound calls differ from one method to the other, with feature code method the calls appear with the App column as “DIAL” and with the AMI method the App column shows as “QUEUE”.

I don´t know what I’m making wrong or if I missing something in how to use correctly AMI, I appreciate if some can provide me some guidance.

Thanks!!!


(Dave Burgess) #2

I think it’s because you’ve got Call Waiting enabled for the extension.


(Fangulo) #3

Hi Dave thanks for the help,

I disable the Call Waiting feature on the extension as you suggested, but it only solved the issue partially, since the call does get in into the queue and appears not to ring to the agent that is busy in an outbound call, however in the CLI the “queue show” command shows the agent as “Not in use” but that does not stop the queue for trying to send the call to the extension, I could verify that in the CLI, in the CDR and in the Queue Log files. Which seems to generate a lot of queue records.

My main doubt is why it does work with the feature code method and it’s different via AMI? Because using the feature code for login is not necessary to disable the call waiting feature in the extensions.

To my understanding while the status of the agent in the queue stays as “Not in use” the queue will see the agent as available, that’s why I think I have all these RINGNOANSWER messages in the queue_log even when the extension is busy.