Queue hold time not playing

Just installed on Ubuntu 8.04 using Asterisk 1.4.22 and FreePBX 2.5.22. Only major problem I have is that I cannot get the queue hold time to announce, even after caller has been on hold well over a minute. I have stacked multiple calls into my test build and I can see in the FOP the amount of hold time for the caller correctly, but it is not played.

Basically what I am seeing in the log file:

[Nov 17 09:23:04] VERBOSE[22485] logger.c: – Executing [[email protected]:4] NoOp(“Local/[email protected],2”, "CAME FROM: 3000 - Blocking VM cause of key: ") in new stack
[Nov 17 09:23:04] DEBUG[22485] app_macro.c: Executed application: Noop
[Nov 17 09:23:04] VERBOSE[22485] logger.c: – Executing [[email protected]:5] Hangup(“Local/[email protected],2”, “”) in new stack
[Nov 17 09:23:04] VERBOSE[22485] logger.c: == Spawn extension (macro-vm, s, 5) exited non-zero on ‘Local/[email protected],2’ in macro ‘vm’
[Nov 17 09:23:04] VERBOSE[22485] logger.c: == Spawn extension (macro-vm, s, 5) exited non-zero on ‘Local/[email protected],2’ in macro ‘exten-vm’
[Nov 17 09:23:04] VERBOSE[22485] logger.c: == Spawn extension (macro-vm, s, 5) exited non-zero on ‘Local/[email protected],2’
[Nov 17 09:23:04] DEBUG[22460] app_queue.c: Dunno what to do with control type -1
[Nov 17 09:23:04] VERBOSE[22460] logger.c: – Nobody picked up in 15000 ms
[Nov 17 09:23:04] NOTICE[22460] app_queue.c: No one is answering queue ‘3000’ (1/0/0)
[Nov 17 09:23:09] VERBOSE[22460] logger.c: – Stopped music on hold on SIP/5060-00899940
[Nov 17 09:23:09] VERBOSE[22460] logger.c: – <SIP/5060-00899940> Playing ‘silence/1’ (language ‘en’)
[Nov 17 09:23:10] VERBOSE[22460] logger.c: – Told SIP/5060-00899940 in 3000 their queue position (which was 1)
[Nov 17 09:23:10] VERBOSE[22460] logger.c: – <SIP/5060-00899940> Playing ‘queue-thankyou’ (language ‘en’)
[Nov 17 09:23:12] VERBOSE[22460] logger.c: – Started music on hold, class ‘default’, on SIP/5060-00899940

A search around the Internet indicated I should add to queues_additional.conf:
queue-holdtime=queue-holdtime
queue-minutes=queue-minutes
queue-seconds=queue-seconds
queue-lessthan=queue-less-than

A full copy of the queue configuration as it stands now:
[3000]
announce-frequency=30
announce-holdtime=yes
announce-position=yes
queue-holdtime=queue-holdtime
queue-minutes=queue-minutes
queue-seconds=queue-seconds
queue-lessthan=queue-less-than
autofill=no
eventmemberstatus=no
eventwhencalled=no
joinempty=yes
leavewhenempty=no
maxlen=0
monitor-type=mixmonitor
monitor-format=wav
music=default
periodic-announce-frequency=150
queue-callswaiting=silence/1
queue-thereare=silence/1
queue-youarenext=silence/1
retry=5
strategy=ringall
timeout=36
weight=0
wrapuptime=36
context=ivr-2
periodic-announce=custom/testWelcome
member=Local/[email protected]/n,0

Any assistance is much appreciated.

You should NEVER edit the queues_additional.conf by hand. That file is created every time you click on Apply changes.

For some strange reasons your file contains:

queue-callswaiting=silence/1
queue-thereare=silence/1
queue-youarenext=silence/1

You are playing one second silence for all your prompts.

Verify your settings in the queue module in FreePBX.