Queue does not respect agent follow me or call forwarding settings

i am pretty sure i have seen this in the past but don’t remember if i ever found a way to make it work.
the platform info
6.12.65-25/12.0.57
the issue
queue, dynamic agent, agent has follow me set, phone is unplugged, ignore queue state is set in extension settings. he logs into the queue and is the only agent in the queue. a queue call comes in, the caller gets placed into the queue but his cell phone in the follow me is not dialed. we tried disabling follow me and use call forwarding on the extension but got the same result. the problem is the phone is broken, a replacement is on the way, but until then he needs to log in and take calls using his cell phone.

Not sure how to fix your issue, but a workaround would be to create a custom extension using the following string in the dial section of the extension: Local/[email protected]

Then log this extension into the queue. I have a remote worker in Canada that doesn’t have VoIP and this works to get queue calls to their cell. Make sure you have an outbound route to match the cell caller id, depending on how you have your out routes set.

thanks jyates01. i remember running into this several years ago as well. converting the extension to a virtual extension was the work around but doing that every time a phone goes off line is not a viable solution. i just opened a ticket on the issue tracker about it as well.

Hi,

I have a similar issue, slightly different.

I have a queue setup with static agents, which includes a static agent that has follow-me settings and no extension logged in. Everything works fine when I have physical extensions logged in, the call comes to the queue takes turn and rings all extensions, physical extension and extension with follow-me on it.

However if there’s no physical extension logged in, the queue doesn’t dial follow-me extension too. the call stays on hold for unlimited time without dialing the follow me. As soon as a physical static extension logs in, the call is passed to that extension and then follow-me extension.

Any suggestions?