Queue Callback Not Working


(Aaron Dale) #1

I’m trying to configure the queue callback and I’m not receiving a callback. In the queue callback logs it shows no information about any call even though I have gone through the prompts and left a number to be called back. Queue%20Capture


(Itzik) #2

What do you see in the queue callback report? Can you post a screenshot?


(Aaron Dale) #3

This is what I see. Thank you for your help!Queue%20Capture2


(Itzik) #4

Request a callback, and see if it shows up there. Note, it’s not live, you need to refresh the page.


(Aaron Dale) #5

Nothing shows in the queue report log when I request a callback.


(Itzik) #6

Can you walk us through the steps you did to reach the callback system?

Also, please post a pastebin link with a call trace. See instructions: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Aaron Dale) #7

I have a test queue setup with the callback setup on.
I called the main phone number for the system that goes through the IVR recording.
I setup number 8 to go to the test queue.
I press 8 and go to the queue.
Before answering the call while the call is waiting in the queue I press 1 and get the recording about the phone number to be used for the callback. I then press 1 to accept then record my name then press #. It says I will get a call back and the phone hangs up.

Capture3 !


(Itzik) #8

Please read the Wiki and post a pastebin link as explained there.

Also, whats the output of:

fwconsole pm2 --list

(Aaron Dale) #9

The command you asked me to run may answer the question as to why it is not working.

Capture1

I ran fwconsole pm2 --restart qcallback and the service started. I ran a test and got a callback. Thank you for your help!


(Aaron Dale) #10

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Itzik) #11

Make sure it says online. The picture shows the status as errored