Queue Callback broken

I’ve opened a ticket with support, but they only respond once a day at 3AM my local time and this system is mission critical and has been not operating normally for a week.

I purchased VQPlus 2 weeks ago to use Queue Callback and it simply has never worked properly (v16.0.18). Calls just get stuck in Pending Callbacks and are either never called back, or receive a callback many hours later. Callers that don’t request a callback are told that they are caller number 100 waiting in the queue, which is not true either.

The log is filling up with:

2022-12-13 17:05 -05:00: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 1052672 bytes) in /var/www/html/admin/libraries/BMO/Modules.class.php on line 472
2022-12-13 17:05 -05:00: PHP Stack trace:
2022-12-13 17:05 -05:00: PHP   1. AGI_AsteriskManager->wait_response() /var/www/html/admin/modules/vqplus/functions.inc/callback-daemon.php:164
2022-12-13 17:05 -05:00: PHP   2. AGI_AsteriskManager->process_event() /var/www/html/admin/libraries/php-asmanager.php:348
2022-12-13 17:05 -05:00: PHP   3. AGI_AsteriskManager->send_request() /var/www/html/admin/modules/vqplus/functions.inc/callback-daemon.php:383
2022-12-13 17:05 -05:00: PHP   4. AGI_AsteriskManager->wait_response() /var/www/html/admin/libraries/php-asmanager.php:251
2022-12-13 17:05 -05:00: PHP   5. AGI_AsteriskManager->process_event() /var/www/html/admin/libraries/php-asmanager.php:348
2022-12-13 17:05 -05:00: PHP   6. FreePBX\Modules->deprecatedFunction() /var/www/html/admin/modules/vqplus/functions.inc/geters_seters.php:11
2022-12-13 17:05 -05:00: PHP   7. debug_backtrace() /var/www/html/admin/libraries/BMO/Modules.class.php:472

The problem doesn’t seem to be with php.ini… It seems like a memory leak.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.