Question about S405 remote provisioning


I just got a S405 today and have been playing around with it, as we are likely going to start using these instead of the Aastras we typically use (the change in pricing models has made the Phone Apps way too expensive… no longer part of a “System Builder” package :frowning: )

With the Aastras, all we would have to do is manually enter the configuration server details in the phone’s web GUI (protocol, address, credentials) and then reboot the phone. It would connect up and either pull down the phone’s config if it existed or just present with the “default” screen to allow logging in.

I tried doing the same thing on the S405, following the instructions at

I added an extension on the FreePBX system and assigned it the “sangoma_default” template (which uses the external hostname). On the phone, I saved the configuration info then clicked on the “Auto Provision” button then rebooted but it didn’t come up with the config.

The format I used for the config server is:

ftp://USERNAME:[email protected]

and I also filled in the FTP username and password in the other fields provided in the Auto Provision page.

Initially I did not put the MAC address of the phone in EPM (I wanted to have the “Login” screen come up), but I also tried putting the MAC address in the extension in EPM, but that didn’t make a difference either.

What did work for me was copying the XML files from the FreePBX server to our TFTP server on our local network, resetting the phone to factory defaults, and rebooting it. It picked up the configs from there and was able to communicate with the FreePBX server. Even any changes I make to the template on the FreePBX server are picked up by the phone when I reboot it, so it does get configuration info from the server; just not initially when attempting to manually enter the auto provision info.

I know I am doing something wrong and/or missing something, but I am just not sure what.

By the way, in the playing around with it I have done today so far, I have to say that I am liking this phone a lot. I like the idea of the VPN server, so for remote extensions it isn’t necessary to open a bunch of ports on the FreePBX server; just the ones for the f[phone to get its configuration (FTP in my case)

Thanks, in advance, for any insight you might have on this.

Sounds like you have a DHCP option 66 set. If you do, and you don’t want your Sangoma phone to use the Option 66 string, you MUST manually set the phone to ignore the option 66 setting. Not looking at a phone GUI at the moment, but it is one or two fields below the configuration URL field on the provisioning page.

Yup, that was it. I disabled both; not sure if I needed to do that, but after disabling those options I didn’t have to reboot the phone – clicking “Auto Provision” gave me the “Login” options on the screen and I was able to log in (the phone rebooted at that point, but I more or less expected that)

Thanks! :slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.