Question about correct Australia & UK Dial Patterns

Hi, I am having issues getting the correct Dial Patterns configured for Outbound Routes in FreePBX.
I am in the US, and have a series of Australian and UK numbers to dial.

AU number example:
614XXXXXXXX

UK number example:
44XXXXXXXXXX

In the Outbound Route, under Dial Patterns, I have the following “match pattern” configured, for a AU contact:

011614XXXXXXXX

Question(s):

  • do I need to put anything in the prepend or prefix field?
  • is this pattern above correct?
  • as I am dialing from the US, I assume I need the “011”

Am on an engagement and only have one day left, so any assistance is greatly appreciated.

jw

Depending on your carrier, likely + or 011 (maybe either) for international

(Time to put your ‘wise virgin’ knickers on :wink: )

I believe there is still some variability in UK number lengths.

Both prepend and prefix are a combination of local policy decisions by your organisation and the provider’s requirements/ There isn’t one correct answer.

appreciate the quick response. Thank you for the suggestion, per your suggestion of using + or 011, I have tried both of those combinations within/without the prepend field, and the ‘match pattern’ field, as well as concatenating the two.
I seem to get different error messages based on the attempts to correctly configure, but need to do some better x-correlation.

That being said, if the number I was given to dial is in the exact length/format of the one I posted in the example, my understanding is that when the call is placed, if the +011 (US exit) is dialed, then the 61 + 9 digit numerical string following, the call will get routed to this trunk.

My ambiguity is how the dial patterns are to be constructed I guess.
I tried this dial pattern combo too:

NXXNXXXXXX
1NXXNXXXXXX
011.

The limitations are just that I can only dial these AU/UK numbers during certain times of the day, and have a fast approaching deadline, hence the post. I appreciate your help.

Hey, thanks for the quick response.
I am the organization :slight_smile: , b/c this infrastructure is being used for a multi-day client engagement.
I just simply have a list of numbers I need to test, based on the formats I posted. that’s all the information I have.

Just my unfamiliarity with configuring these dial patterns, normally I’d shovel dirt until I got it sorted, but was trying to tap the hive-mind. :nerd_face:

only for one small town , Brampton, on the border.

Try allowing and calling this test number:
442030264621

You should hear some instructions. At the beep, say something then press pound. You should then hear your voice played back.

If you hear “Your call cannot be completed as dialed”, that means that the number doesn’t match any Outbound Route.

If you hear “All circuits are busy now”, that means that the provider rejected the call (or you failed to list any trunks for the route).

For the latter case, confirm that you are sending the number in the format they require, and that your account permits calls.to the destination country.

For this example, they may want 442030264621, +442030264621, or 011442030264621.

If you still have trouble, post which trunk provider(s) you are using, and a screenshot of your dial patterns.

hey Stewart1, thank you for the feedback.

I followed your instructions, placed a call to that #, and got this message:

“Your call cannot be completed as dialed”

Based on this error, my outbound route is wrong, so that’s what I’m trying to figure out.

I did get that circuits are busy now message during testing earlier today, but I didnt make detailed notes at that moment, so I am not sure atm the Dial Pattern config I was using. lame, i know

I am using Sangoma/SIPStation for the trunk provider, and below is the dial pattern screenshot.

First make sure that your SIPStation settings are correct:

https://sangomakb.atlassian.net/wiki/spaces/SAF/pages/16187663/International+Outbound+Calling

Next, since you are adding a new Outbound Route (rather than adding patterns to an existing route), you want to be sure that the international calls are not mistakenly matched by other routes in the system.
Put this route below any Emergency routes, but above other existing routes.

Try these patterns:

prepend: +
prefix: 011
match pattern: 44X.
prepend: +
prefix: 011
match pattern 61X.

The trunk sequence should list your SIPStation trunks.

Now try dialing 011442030264621 which should send +442030264621 to the trunk.

hey Stewart, thanks for the recommendation, I did follow the KB article on Sangoma site, to enable International Dialing. One thing you mentioned though re: “a new Outbound Route”, is I didn’t add a new Outbound Route, I just used the current one I have configured, I removed the prior Dial Patterns (listed below), and have been trying the various combinations listed in this thread, by yourself, others, and the ones I listed.
Do you think I need another Outbound Route, if I am just replacing the previous Dial Patterns?

Earlier this week, I was dialing Canadian numbers with this Dial Pattern with no issues:
1NXXNXXXXXX
NXXNXXXXXX

I thought maybe I could just add additional “X” for UK number (which is the only numbers I can dial at the moment, b/c its 3am in Australia right now), as such:
1NXXNXXXXXXXX
NXXNXXXXXXXX

This didn’t work either. I did make notes on call results, and I do see different responses:

number dialed
44XXXXXXXXXX

“all circuits are busy, please try again”

number dialed
01144XXXXXXXXXX

“your call cannot be completed as dialed”

I opened a support case with Sangoma, but as this project ends today, not sure what their SLA is like, so who knows.

Thanks for your assistance, let me know if you have any other suggestions :slight_smile:

j

well, I figured it out, and boy do I feel n00b :yum:
In case anyone else stumbles across this post, and has the same issue(s), here’s the pattern that worked - at least for dialing a UK number, I haven’t tested an AU number yet

011.
NXXNXXXXXX

Thanks to everyone who commented and offered suggestions.

j

I had assumed that you were adding a new route because the route you showed didn’t allow for domestic calling.

As a test, try setting up the route with just one pattern:

prepend: (leave blank)
prefix: (leave blank)
match pattern: X.

Now anything you dial will be sent on the trunk unchanged. Try dialing both 442030264621 and 011442030264621.

If neither works, at the Asterisk command prompt type
pjsip set logger on
paste the Asterisk log for the call at pastebin.com and post the link here.

Edit. I had started to write this before seeing you got it working.

Try dialing 01161290373879
You should hear “welcome to the sipbroker pstn gateway”

See sipbroker.com for options from there.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.