Public IP on the Local network same internet problem

Dear, all,
I’m facing a problem registering softphone FreePBX with public IP on the Local network. (when I’m connected to my office Internet. I have deployed FreePBX in my office and using the same internet on FreePBX) and when I disconnect my office internet and turn on my Mobile data softphone registered successfully.
this problem I s only when I connected to my office internet.
Please help me in this regard.

You’ll need to find out if your firewall supports what’s called a NAT Loopback or NAT Reflection. You’ll need to figure out how to make this work on your firewall if it’s a support function.

Here is an example of how Netgate firewalls address this: Network Address Translation — NAT Reflection | pfSense Documentation

I’m using and port forward in my Mikrotik Router I have not firewall like pfsense.

I am not familiar with Mikrotik routers. You’ll need to find out how to enable this functionality in your router somehow.

which functionality I need to unable in this router??

Try NAT - RouterOS - MikroTik Documentation
If no luck, look at
Hairpin NAT - the easy way - MikroTik
If still no luck, set up DNS at your office to resolve the FQDN of your PBX to it’s LAN address, while other DNS servers (when at home or on mobile data) resolve to the office public IP.

1 Like

I have Port forward in Mikrotik NAT.
what do I need to do more?

This is the solution… that @Stewart1 posted:

“Set up DNS at your office to resolve the FQDN of your PBX to it’s LAN address, while other DNS servers (when at home or on mobile data) resolve to the office public IP.”

Please help me or tell me they way how I can do this.
I have tried Hairpin NAT but no Luck

What router/firewall are you using??? Youll need to #1 setup a FQDN, many ways to do this, its a simple task and point its A record to the Public WAN IP of the network your PBX sits on…

Example… You own domain… You logged into your hosting company, create a subdomain called (or something along those lines) with the A record pointed to your WAN IP for example something like (replace with your actual WAN IP)…

Configure your FreePBX deployment to use this FQDN, configure HTTPS with it, setup a Lets Encrypt cert using that FQDN or some other cert if you dont use LE…

In your local router/firewall… I use Arista ETM NGFW router/security appliances and under Config>Network>DNS Server>Static DNS Entries I make an entry with my FQDN for example and the static LAN IP of the PBX for example…

I have never had any issues using Sangoma Connect/Talk inside or outside my office… Obviously, I skipped over all the step by step instructions on exactly how you need to configure every little setting but gave you the gist… All of that info is in the Wiki

If you havent done so already, you will also need to forward the appropriate ports in your firewall, make sure Responsive Firewall is turned on…

I have Mikrotik Router

So youll need to find out where you make a Static DNS Entry in the DNS Server of your Microtik…

I have tried but still same error 408. on my office internet

Did you actually go create a FQDN?? Does it resolve to your WAN IP?? Did you then configure your PBX to use that FQDN? Did you port forward all the appropriate ports?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.