Provisioning Yealink T26P

Hi there. I’m trying to provision some Yealink T26Ps with the FreePBX Distro 5.211. I’m using the OSS Endpoint Manager.

Everything works except that the Server Host isn’t filling in. So, the phones download the configuration but can’t connect. If I login to the phone’s web admin, the Server Host field is blank. If I manually fill in the IP address for the PBX, the phone works just fine.

The config file for the phone on FreePBX seems to have the information. If I click on OSS Endpoint Device List then click on Specific for a device, the Server Host has the right IP address. It just isn’t making it to the phone itself, although everything else is.

In case it matters, the firmware on the Yealinks is I tried a much older firmware to see if it made a difference and it had the exact problem.

I’m not quite sure where to look. Any suggestions? I have about 20 of these to provision, which isn’t the end of the world, but would prefer not to do it manually.


look in tftpboot and see what is actually being generated. now that the oss epm is “dead” you will probably see more issues going forward. one issue that comes to mind immediately is the file formats and firmware. Yealink, in their infinite wisdom, changed the file format when they released the newer firmware. you might need to read up on the new template/file format on the yealink site and then doctor up the yealink template on freepbx or just modify the config files by hand or last but not least spend some money and purchase the commercial version of the epm.

Thanks for the reply. I didn’t know the OSS Endpoint Manager was no longer supported. I have a license for the commercial EPM I’m not using… I should figure out how to transfer it over.

In the meantime, I can fix it up by hand I suppose.


There is no path to transition from OSS Endpoint Maanager to the Commercial Endpoint Manager automatically.

Open two windows, one with the OSS and another with the Commercial, copy & paste (or highlight, drag & drop) between the fields all values that make sense.

I’m still holding onto the OSS tho, and I’m updating its Yealink packages as I write this.

I have also a couple of patches to submit for it, once I’m happy they’re sane I will post them up.

Wonderful. I’m very interested if you’re willing to share.

I’ve played with the commercial EPM and actually prefer the OSS one. I’m bummed it’s gone, and not because of the price.

It’s not gone, just set aside because the original developer got hired by Schmoozecom to develop the Commercial version - between other things.
Hang on onto it.

This is just a complete wrong fact. Andrew (tm1000) was hired by Schmooze to work on Open Source FreePBX. He has never touched a single line of code in our Commercial EPM. Our Commercial EPM is built 100% by Luke and is 4 years old now. Please do not state things as facts without knowing the real facts. It makes you look foolish.

I have done absolutely no work on Commercial Endpoint Manager and it will probably remain that way for the foreseeable future. I have never once stated that I worked on the Commercial Version.

Oh, my bad, apologies to both.
I inferred that - being Andrew the mind behind the OSS EPM - he was hired to work on the Commercial module exploiting his experience in the niche. Apologies also to Luke.

Nevertheless, the OSS EPM is in need of some TLC, and I’m willing to help - in fact I’m working on two patches and one package update.

I know this doesn’t help you sell the Commercial EPM, but as long as the OSS EPM is included in the Distro and the main FreePBX package, I feel it should stay on par with the great standards of the other modules.

Hope no harm done.

Thanks for clearing things up. Andrew, I appreciate all the work you put into the OSS Endpoint Manager, which has been great. Congratulations on the job. I look forward to seeing what the Schmooze team comes up with next.