Provisioning authentication

Following the basic setup of a new FreePBX server, I wanted to experiment with HTTPS provisioning using a new DB20 basestation and handset.

I found a document on the wiki that I followed, but I’m having a problem configuring HTTPS authentication on the server.

Under port management, I have both HTTP and HTTPS enabled for HTTP provisioning using the default ports. I initially had problems because the server was not listening on port 1433 for the HTTPS provisioning - I rebooted and enabled/disabled the service, but eventually noticed some SSL errors in the logs and wondered if the wildcard certificate I had installed (and had set as the default) was part of the problem.

To rule this out, I installed a Let’s Encrypt certificate and set it as my default (as well as selecting it in my PJSIP settings, and the HTTPS settings in Sys Admin). After doing this, when I re-enabled HTTPS provisioning and could see that the server was listening on the port (TCP/1433).

I’ve now hit an issue when trying to enable authentication. I go into System Admin and then Provisioning Protocols. When I click both (or for that matter if I click HTTPS Only or HTTP Only), leave the username and password blank and then click Save, the server works away for a while and then the page refreshes with None selected, and the username/password boxes are still blank. I have also tried manually specifying the username and password, but the same thing happens; it pauses for a bit, the page refreshes and None is selected.

I am running version and have updated all modules on the server. Any pointers would be greatly appreciated.


Testing with sysadmin 14.0.31 and I can’t reproduce your issue.

Mmm, OK…

I’ve fiddled a bit with the configuration since building it - maybe I will go back to scratch and install the server again. It’s probably a good idea in any case as I’ve lost track of which settings I have changed (this was an experiment as I haven’t used FreePBX in at least 5-6 years)…


OK, so after a clean re-build I am seeing the same symptoms…

There was no “Provisioning Protocols” menu initially after the clean install. It was only after I upgraded all the modules and added back in the base station entry I could then see it.

One quick check - is this as simple as me not having the System Administration Pro license?


Provisioning Protocols is a pro feature:

Thanks for confirming!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.