Provisioning an s305

configuration
Tags: #<Tag:0x00007f7027e55238>

(Tyler Montney) #1

New phone, version 3.0.4.77. Followed this: https://wiki.freepbx.org/display/PHON/Setup+Phone+by+hard+setting+provisioning+server

I hit autoprovision, the phone says it provisioned successfully and checked for firmware. However, it didn’t actually update the firmware (phone had firmware from 2019). It prompts me to enter my extension and password, but says it’s wrong. Logs don’t show any activity from the phone.

System Admin Port Management, Provisioning, API, and Phone Apps are default (both HTTP and HTTPS). Extension is working with a soft phone (MicroSIP). Only odd thing I’ve done is edit pjsip.transports_custom. It was the only way to specify my LE certificate for TLS SIP.

Phone is configured as follows:

Endpoint manager template:

  • Default Internal Template: Yes
  • Default External Template: No (but I’ve set this to Yes before)
  • SIP Destination Address: https://myserver.com:1443 (have had it set to internal and external before)
  • Provisioning Address: https://myserver.com:1443 (have had it set to internal and external before)
  • Force Firmware Version: Recommended
  • Firmware Management: Slot 1 and 2 populated with latest and latest - 1 version.

When checking the phone logs, it does make reference to failing to find a firmware ROM (404 not found). I’m unsure of what the actual endpoints are to test them via a browser. I feel like maybe I put the wrong values for the phone autoprovisioning portion. Phone is on the local network. I’d prefer to use the FQDN as I want to use HTTPS (and avoid SSL errors).


#2

When you say you were given a login prompt, where were you seeing that? For example, if it was on the phone, were you provided with a Login key on the idle screen? If so, the phone sounds like it is pulling a config from the server, it just happens to be one for Hot Desking. This usually happens if a MAC address is not entered in the extension’s mapping in Endpoint Manager.

If that’s the case, you can add your mac to the extension’s mapping and try to reconfigure. As for the failed logins, if the phone was prompting for a hot desking login, the password should be your user’s voicemail password. The global passwords found in Endpoint Manager’s Global Settings should also work.

If the prompt is not related to hotdesking, more details about when the prompt is showing up, or anything else on screen would help to understand what you’re seeing.


(system) closed #3

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.