Provider drops trunk (Freepbx not responding to [email protected])

So I’ve just updated a very old installation still using chan_sip.
Now I’ve managed to get it all working but I keep getting this in the logs

75151	[2022-05-02 12:59:59] ERROR[2766] pjproject: sip_transport.c Error processing 367 bytes packet from UDP "HIDDEN":5060 : PJSIP syntax error exception when parsing 'Status Line' header on line 1 col 6:	
75152	SIP sip:tomazbriski:5060 SIP/2.0	
75153	Via: SIP/2.0/UDP "HIDDEN":5060;branch=z9hG4bKh9nbif10cgnfqppkhe50	
75154	Call-ID: [email protected]"HIDDEN"	
75155	To: sip:[email protected]	
75156	From: <sip:[email protected]"HIDDEN">;tag=2199f81f23baed67f3f8e01d1d79a34a0g0k6v3	
75157	Max-Forwards: 70	
75158	CSeq: 158462 SIP	
75159	Route: <sip:"HIDDEN":5060;lr>	
75160	Content-Length: 0

Now I’m guessing it’s the provider trying to see if the server is up. I tried setting qualify to 0 in pjsip settings.

I’m guessing this is why the trunk keeps dying on me, unless I make a call out, then it stays alive for about 1 minute.

“SIP” (first word of first line) is not a SIP method. PJSIP rejects the packet because it is nonsense.

So, the solution is get my provider to use PJSIP or use SIP for the trunk?

EDIT:

Miss understood your message.

So if I understood correctly and it’s nonsense in any case, how do I deal with this being sent by my provider? The provider has a failover to my mobile number. If my server doesn’t respond my provider transfers the call to my mobile number, unless I make a call out through Freepbx. Then it works for 1 minute and then everything goes to mobile number again.

I would talk to the provider about it.

Neither. Get your provider to comply with RFC 3261, the core SIP specification.

What is causing particular confusion here is that the first three characters of a response are SIP, the next one should be “/”. It looks like PJSIP has made the decision that this is a (badly formed) response, so isn’t interested in looking ahead to make a better diagnosis (it isn’t a SIP validation tool, and no-one in their right mind would define SIP as a SIP method), and, as it is an unsolicited response, the correct action is to ignore it.

The method normally used for this is OPTIONS.

So I set qualify to 2 seconds from 0. That did the trick it worked. But I still keep getting spammed by that ping from my provider. Need to give them a call.

Now since I’ve change from FreePBX 12 to 16 there’s so many new things I’m a bit overwhelmed.

BUT now, for some reason, I have the strange issue where I can’t connect from outside, over Bria softphone. As soon as I go off Wifi it’s just stuck at registering…

Keep in mind, my network is the same, I just shut down FreePBX 12 VM and installed FreePBX 16 on new VM and restored from legacy backup and converted all CHAN_SIP to PJSIP extensions. Also declined FreePBX built in firewall.

I was to tired to keep up, so I just shut down the v16 virtual machine and brought up version 12 for now.

EDIT:

Yep, a power nap helped. Had to setup correct IP routing.

Talked to the provider, within 30 seconds we fixed the issue. He has no idea why this happened, must have been a brain fart. No more errors now and I don’t need to re qualify every 2 seconds to stay online.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.