Prosody Package is out of date. Please upgrade prosody

FreePBX 13.0.1beta3.45
Asterisk 11.7.0
SHMZ release 6.4 (Final)

When attempting an XMPP ‘Upgrade to 13.0.2.3 and Enable’ (via GUI), I receive the error below:

Please wait while module actions are performed
Installing xmpp
Prosody Package is out of date. Please upgrade prosody
Error(s) installing xmpp:
Failed to run installation scripts
Updating Hooks…Done

I’ve also executed yum -y install prosody (via CLI), but the receive the error message below:

Loaded plugins: fastestmirror, kmod
Repository schmooze-commercial is listed more than once in the configuration
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package prosody.x86_64 0:0.9.1-13shmz will be updated
—> Package prosody.x86_64 0:0.9.1-102.shmz65.1.15 will be an update
–> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: prosody-0.9.1-102.shmz65.1.15.x86_64
–> Finished Dependency Resolution
Error: Package: prosody-0.9.1-102.shmz65.1.15.x86_64 (schmooze-commercial)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

What am I missing here? Please provide feedback.

Other posts suggest updating to 6.x to fix this…but it looks like you already have.

The OpenSSL package might need to be updated; does yum update list any other packages that need an update?

You need to update your distro. Have you done so? Doesn’t look like it.

No other packages are listed.

Please update your distro: http://wiki.freepbx.org/display/FD/Updating+FreePBX+Official+Distro

Updating as we speak. I’ll provide feedback afterwards. Thanks.

Upgrading to 5.211.65-1 resolved this issue. Thanks!

1 Like

http://wiki.freepbx.org/display/FD/Updating+FreePBX+Official+Distro

"End of Life unsupported tracks are:

… 5.211.65"

I am running FreePBX 12.0.74 on Centos. Prosody seems to have been installed at some stage and my system processes updates more or less automatically.

I recently discovered that the last Prosody update failed. When I run it manually I get

Now updating prosody …

Installing package(s) with command yum -y install prosody ..

Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: repos.mia.quadranet.com
 * epel: www.gtlib.gatech.edu
 * extras: repos.mia.quadranet.com
 * updates: repos.mia.quadranet.com
Resolving Dependencies
--> Running transaction check
---> Package prosody.i686 0:0.9.1-102.shmz65.1.15 will be updated
---> Package prosody.i686 0:0.9.8-4.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version
Repository Size

================================================================================
Updating:

Transaction Summary

================================================================================
Upgrade 1 Package(s)

Total download size: 245 k
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : prosody-0.9.8-4.el6.i686
    1/2Error unpacking rpm package prosody-0.9.8-4.el6.i686

warning: /etc/logrotate.d/prosody created as

/etc/logrotate.d/prosody.rpmnew
error: unpacking of archive failed on file /etc/prosody/certs: cpio:
rename
Verifying : prosody-0.9.8-4.el6.i686
1/2prosody-0.9.1-102.shmz65.1.15.i686 was supposed to be removed
but is not!

  Verifying  : prosody-0.9.1-102.shmz65.1.15.i686
    2/2

Failed:
  prosody.i686 0:0.9.1-102.shmz65.1.15        prosody.i686

0:0.9.8-4.el6

Complete!

.. install failed!

Any one a clue how to fix this?

your existing prosody package is from the FreePBX commercial repo, instructions here for adding that repo to your system.

http://wiki.freepbx.org/display/FCM/Installation+on+CentOS+and+RHEL+based+systems

Hi Preston

thanks for your reply. but it unfortunately it did not solve the problem. I added the repo but it turned out it was already on the system.

[[email protected] ~]# wget -P /etc/yum.repos.d/ -N NOTALLOWED TO POST LINKS yum.schmoozecom.net/schmooze-commercial/schmooze-commercial.repo
–2015-08-23 18:44:56-- NOTALLOWED TO POST LINKS yum.schmoozecom.net/schmooze-commercial/schmooze-commercial.repo
Auflösen des Hostnamen »yum.schmoozecom.net«… 162.253.134.138, 199.102.239.168
Verbindungsaufbau zu yum.schmoozecom.net|162.253.134.138|:80… verbunden.
HTTP Anforderung gesendet, warte auf Antwort… 200 OK
Länge: 287 [text/plain]
Datei auf dem Server nicht neuer als die lokale Datei »»/etc/yum.repos.d/schmooze-commercial.repo«« – kein Download.

It said file not newer than existing one on the server --> no download

[[email protected] ~]# yum clean all
Geladene Plugins: fastestmirror, security
Cleaning repos: base epel extras schmooze-commercial updates virtualmin
: virtualmin-universal vz-base vz-updates
Räume alles auf
Cleaning up list of fastest mirrors
[[email protected] ~]# /var/lib/asterisk/bin/freepbx_setting MODULE_REPO NOTALLOWED TO POST LINKS mirror1.freepbx.org,NOTALLOWED TO POST LINKS mirror1.freepbx.org

I skipped instaling fail2ban, have this already.

But another problem: cannot change locale

sh: warning: setlocale: LC_ALL: cannot change locale (en): No such file or directory
sh: warning: setlocale: LC_ALL: cannot change locale (en): No such file or directory
trying to run as user asterisk:

sh: warning: setlocale: LC_ALL: cannot change locale (en): No such file or directory
sh: warning: setlocale: LC_ALL: cannot change locale (en): No such file or directory
sh: warning: setlocale: LC_ALL: cannot change locale (en): No such file or directory
[MODULE_REPO] changed from previous value: NOTALLOWED TO POST LINKS mirror1.freepbx.org, NOTALLOWED TO POST LINKS mirror2.freepbx.org] to new value: [ NOTALLOWED TO POST LINKS mirror1.freepbx.org,NOTALLOWED TO POST LINKS mirror1.freepbx.org]

Then I tried updating prosody via Virtualmin and it showed me the same result as before:

Now updating prosody …

Installing package(s) with command yum -y install prosody ..

Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.5ninesolutions.com
 * epel: mirror.steadfast.net
 * extras: mirror.5ninesolutions.com
 * updates: mirror.5ninesolutions.com
Resolving Dependencies
--> Running transaction check
---> Package prosody.i686 0:0.9.1-102.shmz65.1.15 will be updated
---> Package prosody.i686 0:0.9.8-4.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package           Arch           Version                  Repository      Size
================================================================================
Updating:

Transaction Summary
================================================================================
Upgrade       1 Package(s)

Total download size: 245 k
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : prosody-0.9.8-4.el6.i686                                     1/2Error unpacking rpm package prosody-0.9.8-4.el6.i686
 
error: unpacking of archive failed on file /etc/prosody/certs: cpio: rename
  Verifying  : prosody-0.9.8-4.el6.i686                                     1/2prosody-0.9.1-102.shmz65.1.15.i686 was supposed to be removed but is not!
 
  Verifying  : prosody-0.9.1-102.shmz65.1.15.i686                           2/2 

Failed:
  prosody.i686 0:0.9.1-102.shmz65.1.15        prosody.i686 0:0.9.8-4.el6       

Complete!

.. install failed!

By the way, couldn’t I simply uninstall prosody? I am currently just using GPL modules

Yes just uninstall it and uninstall xmpp and you’ll be fine

Something that I have done is exclude prosody from the EPEL and EPEL-testing repos. Add the following line to /etc/yum.repos.d/epel.repo and /etc/yum.repos.d/epel-testing.repo under each repo entry

exclude=prosody

You could also do this for other repos that you experience this problem on (shouldn’t be any, but just in case).

My epel repo file:

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
exclude=prosody

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1
exclude=prosody


[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1
exclude=prosody

This should help solve this long-term.

I simply deinstalled Prosody since I don’t use it. Error gone and no problems after a months time so far.