Problems with SIP Options on Internode Nodephone

Hi all…

Need some help with this one. I’m not sure if it’s me or Internode. This is Chan_sip not PJSIP, haven’t been able to get enough time to go thru and get an understanding of the changes.

Some weeks ago Internode changed a SBC which threw all of the PBX’s offline. The fix was easier as the Register String just required the [Username] be added to the end of the string which wasn’t required on the old box and normal service resumed for all except my test box. It has steadfastly refused to accept inbound calls. Looking at the debug printout on the console I saw this:

<— SIP read from UDP: —>
SIP/2.0 403 Forbidden
Call-ID: [email protected]:5060
From: “Unknown” sip:[email protected];tag=as359c8628
Via: SIP/2.0/UDP;received=;rport=10000;branch=z9hG4bK65b7856d
Server: SIP/2.0
Content-Length: 0
Supported: replaces, timer
Max-Forwards: 69
User-Agent: FPBX-15.0.24(16.28.0)
Date: Thu, 01 Dec 2022 08:06:06 GMT
Contact: sip:[email protected]:5060

This brings up a 403 Forbidden from Internode.

The trunks register and appear as such in the Info Report. Their FROM: headers are correct, as below.

The FROM: header should contain [Username], not the “Unknown” string.

I have to be missing something obvious! I’ve tried every option in the peer and user details I can find to force a change, even rebuilt the box from scratch.
FreePBX 15 Asterisk 16

Thanks in advance…Craig.

The 403 error response to OPTIONS is by itself not a problem. Asterisk treats that as “reachable” for qualify purposes, and the response to REGISTER may be different.

However, the PBX appears to be behind a router/firewall that rewrote the source port, and it’s possible that Internode treats that as a security issue or is otherwise an error.

Specifically, the PBX seems to have Bind Port set to 5060 (default for FreePBX 15 is 5160, but I assume that you changed it). But the Via header sent by Internode shows that the request was received from port 10000. Setting your router/firewall to forward UDP port 5060 to the PBX should fix that, and supporting external extensions would require that anyway. Of course, set up FreePBX firewall and/or the hardware firewall to keep unwanted attacks out. If you don’t need external extensions, setting the hardware firewall to not rewrite source ports should also work.

If the router/firewall is supplied by the ISP and has analogue phone ports, it’s possibly using port 5060 internally and you’ll have to choose a different Bind Port for Asterisk.

If my analysis is incorrect, please post a failing REGISTER request and the corresponding responses. If registration is successful but you don’t receive calls, I suspect that Internode is sending them to port 5060 but the rewrite is causing the problem.

Thanks Stewart…it made me think. Your analysis was correct. The forwarding rule was in place, but I had activated the internal phone on the router to check if the problem was with Internode originally, then dis-abled it. It is the original Technicolor TG-1 so I changed the VOIP port to something different and the inbound calls came in. I had used Billion 8900 R3’s in the other sites and these don’t support internal voip.
Obviously once active the TG-1 doesn’t release the port even when the function is turned off.
Thanks again. I needed that clue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.