Problems with playback in System Recording

Hi, i’ve uploaded this file from the web interface of the module System Recordings, the file is PCM Encoded 16Bit 8Khz Mono, and i’m using with another PBX (Trixbox) without problems.

I’m delevoping a new PBX based on Ubuntu Gutsy, and i can’t play system recordings, i’ve this errors from asterisk full log:

[Nov 7 17:38:49] WARNING[5159] file.c: File custom/ivr-piera-musica does not exist in any format
[Nov 7 17:38:49] WARNING[5159] file.c: Unable to open custom/ivr-piera-musica (format 0x4 (ulaw)): No such file or directory

This are the files: (i’ve encoded with sox the same file in gsm, but without good result)

[email protected]:/var/lib/asterisk/sounds/custom# ls -al /var/lib/asterisk/sounds/custom/
total 376
drwxrwxr-x 2 asterisk asterisk 4096 2007-11-07 17:31 .
drwxrwx— 3 asterisk asterisk 4096 2007-11-07 17:40 …
-rwxrwxrwx 1 asterisk asterisk 34617 2007-11-07 17:31 ivr-piera-musica.gsm
-rw-rwx— 1 asterisk asterisk 335716 2007-11-07 18:15 ivr-piera-musica.wav

Someone have seen the same problem ?

Thank you

Please, someone can help me ?

I’m refer to this bug:

http://www.freepbx.org/trac/ticket/1954

There is a solution ?

Thx

Please give me a feedback

I’v upgrade to 2.3.1.1 but the problem persist, please someone have a agile solution ?

I seem to remember somebody else posting something similar to this a few months ago. The problem ended up being that the install was not looking in the “normal expected” place you think it was supposed to. Based on the error it is either a permissions problem or it can’t access the file which would be true if it was not looking at the /var/lib/asterisk/sounds folder to start with.

Search the forums and take a look around as the solution was to create a symlink for the custom directory someplace different pointing to this location and it then worked.

Take a look at lsof or strace to track the files and path of said files that asterisk has opened will also help.

By doing a ‘chmod a+x /var/lib/asterisk/custom’. Maybe it will sort the issue for someone else too.

This is the final fix:

ln -s /var/lib/asterisk/sounds/custom /usr/share/asterisk/sounds/custom
chown -R asterisk:asterisk /var/lib/asterisk
chown -R asterisk:asterisk /var/lib/asterisk

paolomainardi, I can’t thank you enough.

I didn’t notice any log errors/warnings, but I have had the problem of recorded messages not playing back for ages.
It was driving me crazy. Scanned the forums, was even on the #freepbx and #asterisk IRC to no avail.

This fix worked like a charm. Kudos to ya.

Cheers.

I am using an install on Linode from a StackScript (http://www.linode.com/stackscripts/view/?StackScriptID=4483)

Everything else works except commands which play sound files. The result is usually that the entire dialplan fails and my provider can’t even connect the call. IVR doesn’t work. Playback command doesn’t work.

From the link you gave:

“This installer does not install DAHDI”

DAHDI is used as a timing for some of the playback functions. This may be your problem.