Problems with phone apps

I have a PBXact machine that came with phone apps. When I set up the profiles in EPM the Aastra phones take the information but I continue to get an error when I try to use the button on the phone. I get an error with all of the phone apps that say something like " (what ever the app is) is not authorized in the API module for extension ###"

I feel like I have just not enabled something somewhere. Any help on this would be appreciated.

Please note I am very new to FreePBX so please show a little grace when answering if I don’t quite understand. :wink:


Have you reviewed our wiki on phone apps. It walks you through the setup process.

@tonyclewis do you have that link? Everything I have found I think I have followed.

I have read the wiki and tried to follow everything by what it said and have done the following:

I checked to make sure that the user had the phone apps enabled and licensed to our box.
I mapped the apps to the phone using EPM using the xml-api and choosing the appropriate app.
From a command prompt I restarted the service using this command: fwconsole restart restapps

I am still having the following error:

Find Me/Follow Me is not authorized in the Phone Apps module for extension 102

Any ideas other than have you read the wiki of what might be the issue?

Is the FindMe/Follow me enabled for the user in UCP?

Hi @Kingjohn

In User Management, ensure that the user has permission to use phone apps at all, and ensure they have permission to use the specific phone app being tested. This can be done at the user level, or at the group level with the user permissions being set to inherit.

I created a new group and put the users in there with the updated permissions and it finally worked. I am not sure why the other group would not pass the permissions along. Kind of frustrating but at least I got it working.

Thanks all for the help!

1 Like