Problems with MeetMe and SIP Trunk

I have a trixbox configuration (all up-to-date running version 2.4.0.1) which has been working perfectly without any issues making or receiving calls. I have just recently tried to add MeetMe functionality and created an conference. I had set the User PIN to: 1111 and the Admin PIN to: 2222.

When I dial in, the system says, “Please enter the conference PIN number”. Regardless of which PIN number I enter (whether User or Admin), the system says, “That is not a valid conference number, please try again.” and proceeds to disconnect the call.

What is odd is that if I enter an incorrect PIN number, it says “That PIN is invalid for this conference. Please enter the conference PIN number.” It will allow me to continue entering PIN numbers as long as I don’t enter either the User PIN or the Admin PIN.

In looking at the “full” log under /var/log/asterisk", I notice whenever attempting to enter a conferencere there is an error message “WARNING[XXXXX] app_meetme.c: Unable to open pseudo device”.

I have seen references to zaptel devices, etc. However, in my case, I am not using that. Any recommendations would be appreciated.

I think you need to load the Zaptel Dummy driver to make conferences work. You can run genzaptelconf from a linux command line on a lot of the distro’s out there. That script should find no Zap hardware and install Zap/Dummy for you.

Yes John you are correct. even if using a Sip trunk you need to have the ztdummy driver loaded for meetme to work.

So it turns out that the issue was the result of the ztdummy driver failing to load. We are using SIP trunks (so no real need for zaptel, other than the ztdummy for timing for MeetMe). It turns out the issue was the trixbox was loading the kernel-PAE. By having grub load the standard kernel, zaptel service (in rc3.d) now starts up correctly. MeetMe works like a charm.

Thanks for the feedback, could not have found the root cause without you guys pointing me in the right direction. Now if I could only figure out the DTMF issue.

to solve all DTMF
GOOD provider / cards
ULaw / Alaw codec’s only
rfc2833 ONLY… no in-band
low lag time to provider / crappy ping times = faults in the DTMF
asterisk 1.4.x… asterisk 1.2 does not handle DTMF right

Excellent catch thanks for the summary. It appears this bit us.

Is this a known error / feature / issue with Trixbox load.

I would think a default install of Trixbox would have the correct
kernel selected as a default, or does the person who performs the
initial install select it the first time through ?

When I say correct kernel, I mean a kernel which actually
has the zaptel modules included with it !

I came here to try to solve my own WARNING[XXXXX] app_meetme.c: Unable to open pseudo device on asterisk 1.6, which no longer uses zaptel. On 1.6, the correct solution is to grab the latest version of dahdi-linux from source(this is important, an older version still failed for me), and compile it (make and make install). It now includes the dummy driver in the base, so that should be all you need to do outside of loading the dahdi module. (modprobe dahdi)

So I have don’t have Asterisk 1.6, but I do show the following mod is loaded:

[[email protected] dev]# lsmod | grep dummy
dahdi_dummy 9384 0
dahdi 190728 13 dahdi_dummy,xpp,dahdi_transcode,wcb4xxp,wctdm,wcfxo,wctdm24xxp,wcte11xp,wct1xxp,wcte12xp,wct4xxp

So it appears that I should be using the dahdi dummy I would guess…wonder if i should try to download and recompile like you did? Guess I’ll give it a try.

Ah ok…forget zapdummy, etc.

I had run all the updates for the modules through the portal when i first installed system.

It wasn’t until after running “yum update” in the cli and doing a reboot that it finally worked!

There’s a lot of good info out there, but unfortunately a lot is for the old stuff!

Hope this helps others with new stuff!