Problems with insecure ssl setting in basefile edit

We have an issue with some sites where over the easter period call-logs and status stopped working on P310 handsets. The handsets had been at some point upgraded to 4_19_2 and EPM to

on first look pressing the call log or status got nothing more than a blank screen, checking the ‘basefile edit’ page i can see that the
<setting id="allow_insecure_ssl" value="1" />
is still there . but when checking the config file created I see that its not being carried over to that.

manually adding this line to the config file apps work again.

In my mind im sure P3xx apps had to be https as in the case here but with out the insecure ssl option they now don’t work as its an onsite system with a self signed cert,

It seemed to coincide with the changes to the EPM and server_enviroment setting

So can all apps on the P310 and P320 work in http mode or is there a reason this “insecure ssl” basefile entry isn’t going over any more.

So in EPM basefile edit we have

  <setting id="hide_completed_elsewhere" value="__callCompletedElsewhere__" />
  <setting id="server_environment" value="DPMA" />
  <setting id="allow_insecure_ssl" value="1" />

but the file created has

  <setting id="hide_completed_elsewhere" value="0"/>
  <setting id="server_environment" value="Switchvox"/>

the server enviromet is correctly changed

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.