Problem with Zulu UC in Android


(Ntranx) #1

I am testing the commercial Zulu UC module for 2 devices, in general on a computer within the zulu network it behaves very well I have two-way audio, the problem is when I use zulu on the mobile I only hear the voice of the operator when calling * 43 but I am not able to hear my voice (within the local network), I think the problem has to do with Stun and Turn but I am a newbie in this and my head is hurting, it should be noted that I am under a pfsense firewall and certain domains Are blocked


(Ntranx) #2
  • Zulu Server: 15.0.58.9 © Sangoma
  • PBX: v15.0.17.24 © Sangoma

(Lorne Gaetz) #3

Forget about Zulu mobile and use Sangoma Connect instead. It’s a better mobile client, and the Zulu licensing works for both.


(Defcomllc) #4

I agree, Ive been testing Sangoma Connect on mobile for a few weeks now in place of Zulu and its been excellent. Only thing is, no chat feature to collaborate with office employees using Zulu on their desktops?? Chat feature is really nice for instant employee collaboration. Seems like we are stuck between two apps at the moment?


(Ntranx) #5

The truth is, as @defcomllc says, I am quite interested in zulu chat that I do not have it in sangoma connect and I would like to connect safely to sangoma connect but my firewall is blocking all connections and I do not know exactly which ports to open for sangoma connect


(Lorne Gaetz) #6

https://wiki.freepbx.org/display/CONNECT/Technical+Details


(Defcomllc) #7

Sangoma Connect uses TCP… So you need to open whatever your PJSIP TCP Bind port is… You can find this is Asterisk SIP Settings under the CHAN_PJSIP tab…


(Ntranx) #8

yes but i want to use an encrypted connection i found it here
https://wiki.sangoma.com/display/CONNECT/Secure+Calling+for+Sangoma+Connect+Mobile
in Secure Calling for Sangoma Connnect but I don’t see the menus to choose the domain fqdn


#9

That’s in “Settings” -->“Advanced Settings”. On this page go down to the " Sangomaconnect" area.


(Ntranx) #10

yes I know but the FQDN configuration does not appear


(Defcomllc) #11

Mine looks the same… No Enable Secure Calls option in Settings>Advanced Settings>SangomaConnect section like in the Wiki…


(Ntranx) #12

???


(Pvr2002) #13

I have been trying to locate the Enable Secure Calls option as well but it isn’t on my system where they say it should be in the wiki.


(Defcomllc) #14

Yep, not in my settings either. Was hoping Sangoma would have responded on this already.


(Simon Telephonics) #15

There were three replies from Sangoma employees already in this thread. Have you opened a support ticket?


(Defcomllc) #16

Yea, and all 3 of their replies pointed to the Wiki and area to enable it which no longer exists as shown in the above posted screenshots . Yes, I have a ticket open today.


(Simon Telephonics) #17

I do not use the module but just a hunch, you might have a different version installed than what is demoed on the wiki. Check for updates.


(Lorne Gaetz) #18

Wiki was stale. I have since updated it.

If you want to use TLS signaling in Sangoma Connect, ensure the module is up to date. You can either hard set the transport to TLS in the extension advanced settings, or you can leave that set to Auto and set the default transport on the SNG Connect Settings tab.

We are still actively working thru the various SRTP usage cases which corresponds to the media encryption and opportunistic settings on the extension advanced tab. Not all signaling/media encryption combinations are supported by the Connect client.


(Defcomllc) #19

Thank you for the reply.


(system) closed #20

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.