Problem with SSH backup on FreePBX 13 and 14, but not 15

backup
Tags: #<Tag:0x00007f70290cb0e8>

(Adolfo) #1

I’m setting up some FreePBX instances to backup to an SSH server.
I have this working on FreePBX 15, but whenever I try to do this on FreePBX 13 or 14 I get this same error:

Initializing Backup 3
Backup Lock acquired!
Running pre-backup hooks…
Adding items…
Building manifest…
Creating backup…
Storing backup…
exec request failed on channel 0
SSH Error (255) - Received [] from /usr/bin/ssh -o StrictHostKeyChecking=no -i /home/asterisk/.ssh/id_rsa -l USERNAME SSHSERVERIP -p 22 ‘mkdir -p /test’
exec request failed on channel 0
Running post-backup hooks…
Backup completed with errors!

The SSH server does receive a file from FreePBX… but it’s not a .gz file.
I ran fwconsole chown and chmod 755 /home/asterisk in case it was a permissions issue with the id_rsa file.

Any ideas?


(Dave Burgess) #2

Unless the SSH user is ‘root’, this should fail basic security checks on the remote system.


(Adolfo) #3

SSH user is not root. Should I ignore that error then?
For some reason the backup received in the remote SSH server is just a file with the name of the backup… no date/time or tar.gz extension.

This does not occur when receiving a backup from a FreePBX 15 system to this same remote SSH server.


(Adolfo) #4

Nevermind… figured it out. I created a folder with the name of the backup… then the backup was received properly within that folder. whew


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.