Problem With recording

Hi everybody. I’ve got a small problem with freePBX and the module recordings use the last available version from the online repo). This problem wasn’t here in previous version. When I wan’t to register something, I enter my extension number, I call the *77, no problem here, I can see the file is created in /tmp as /tmp/extensionnumber-ivrrecording.wav. The permission on this file are:
-rw-r–r-- 1 asterisk asterisk

And when I try to save it, it gives me an error:

[ERROR] The Recorded File Does Not exists:

I run apache as user www (maybe the problem comes from here) but www is part of the group asterisk, so it should have read permission on the file. I have looked at the code of the page modules/recording/page.recording.php, and I saw that there’s a new check

 if (!file_exists($recordings_save_path . "{$dest}ivrrecording" . $suffix)) {
                                echo "<hr><h5>"._("[ERROR] The Recorded $recordings_save_path{$dest}ivrrecording.$suffix File Does Not exists:")."</h5>";
                                echo $recordings_save_path."{$dest}ivrrecording.$suffix<br><br>";
                                echo "make sure you uploaded or recorded a file with the entered extension<hr>";

This check wasn’t present in previous version. If I comment it, everything works (www has write permission in /var/lib/asterisk/sound/custom). But I don’t understand how the check can fail. The function file_exists should return true if the file exist, and www has read permission on it.

I’ve also tried to run apache under asterisk just to be sure, it doesn’t work either. Anybody else have this problem?