Problem with outgoing calls recording

asterisk 1.4.18
freepbx 2.4.0.0

In extension config if I set "Record Outgoing=Always"
it’s everything ok with calls to external numbers through trunk
they are recorded

but if i dial to another local extension there is no recording

in first case in debug output I see than calling extension recording settings are checked (232 is my ext, 400898 ext number)

    -- Executing [[email protected]:3] Macro("SIP/232-09c37720", "record-enable|232|OUT|") in new stack
    -- Executing [[email protected]:1] GotoIf("SIP/232-09c37720", "0?2:4") in new stack
    -- Goto (macro-record-enable,s,4)
    -- Executing [[email protected]:4] AGI("SIP/232-09c37720", "recordingcheck|20080307-155718|1204873038.31") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
  recordingcheck|20080307-155718|1204873038.31: Outbound recording enabled.
  recordingcheck|20080307-155718|1204873038.31: CALLFILENAME=OUT232-20080307-155718-1204873038.31
    -- AGI Script recordingcheck completed, returning 0
    -- Executing [[email protected]:999] MixMonitor("SIP/232-09c37720", "OUT232-20080307-155718-1204873038.31.wav") in new stack
    -- Executing [[email protected]:4] Macro("SIP/232-09c37720", "dialout-trunk|3|400898||") in new stack 

in second only called ext recording settings are checked resulting no recording (my ext 232 i’m calling 202)

    -- Executing [[email protected]:8] Macro("SIP/232-09c82ae0", "record-enable|202|IN") in new stack
    -- Executing [[email protected]:1] GotoIf("SIP/232-09c82ae0", "0?2:4") in new stack
    -- Goto (macro-record-enable,s,4)
    -- Executing [[email protected]:4] AGI("SIP/232-09c82ae0", "recordingcheck|20080307-160218|1204873338.33") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
  recordingcheck|20080307-160218|1204873338.33: Inbound recording not enabled
    -- AGI Script recordingcheck completed, returning 0
    -- Executing [[email protected]:5] NoOp("SIP/232-09c82ae0", "No recording needed") in new stack
    -- Executing [[email protected]:9] Macro("SIP/232-09c82ae0", "dial||tr|202") in new stack

have no time right now to seek for cause of such strange behavior in guts of dialplan
may be later next week

any ideas?

Seems the freepbx doesn’t record internal calls(extension to extension).

But, there is a ticket open to solve this question.

take a look: =D

http://www.freepbx.org/trac/ticket/1828

I am new to freepbx but I have successfully configured the system to work as per my requirement.
My question is as follows:
During an outbound Call say for example I am calling to U.S. Now My question is after I make an outbound call to U.S and say the call is connected and the conversation successful. In the Billing Report the CDR has the details of the called number and its OK and is just what it should be. but say if the called is not Answered and there is a timeout and I get a reorder tone, in the Billing Report it show Answered which is not correct it should have No Answer so my question to all is that how to only show the Answered call in CDR and not the No Answered Calls. Again as per my understanding the Duration of the Call should only be the conversation time right but in the CDR it shows the moment from the call is initiated which is also I think not correct.
So I would really appreciate if any one can help me resolve this issue

I think the first thing you need to learn is how to post. This thread is on call recording.

You need to start your own thread. Nobody will respond to a your post, you hijacked this thread. It’s like interrupting a conversation.